当前位置:编程学习 > C/C++ >>

zoj3203 Light Bulb-----三分复习

Light Bulb
Time Limit: 1 Second      Memory Limit: 32768 KB
Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

Input
The first line of the input contains an integer T (T <= 100), indicating the number of cases.
Each test case contains three real numbers H, h and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.
Output
For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..
Sample Input
3
2 1 0.5
2 0.5 3
4 3 4
Sample Output
1.000
0.750
4.000
 
根据题意可以列出方程:设在地上的那段影子的长度为l1,  l1/D=(h-L)/(H-L),得到l1=(h-L)*D/(H-L),所以影子的总长度为l1+L=(h-L)*D/(H-L)+L,只有一个未知数L,把L进行三分,在(0,h)这个范围内。
[cpp]
#include<iostream> 
#include<cstdlib> 
#include<stdio.h> 
#include<algorithm> 
#include<math.h> 
#define eps 1e-15 
using namespace std; 
double H,h,D; 
double cal(double xx) 

    double ans=(h-xx)*D/(H-xx)+xx; 
    return ans; 

double solve() 

    double left,right; 
    double mid,midmid; 
    double mid_area,midmid_area; 
    left=0;right=h; 
    while(left+eps<right) 
    { 
        mid=(left+right)/2; 
        midmid=(mid+right)/2; 
        mid_area=cal(mid); 
        midmid_area=cal(midmid); 
        if(mid_area<midmid_area) left=mid; 
        else right=midmid; 
    } 
    return cal(right); 

int main() 

    int t; 
    scanf("%d",&t); 
    while(t--) 
    { 
        scanf("%lf%lf%lf",&H,&h,&D); 
        double f=solve(); 
        //double ss=cal(f); 
        printf("%.3lf\n",f); 
    } 

补充:软件开发 , C++ ,
CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,