当前位置:编程学习 > C/C++ >>

1013. Battle Over Cities (25)

题目描述:
It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.
For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.
Input
Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.
Output
For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.
Sample Input
3 2 3
1 2
1 3
1 2 3
Sample Output
1
0
0
 
分析:
(1)题目给出一张图,以及几条边。要求当去掉其中的一个顶点后为了使剩下的顶点可以连通需要增加多少条边。
(2)其实只要考虑去掉这个顶点后,剩余的顶点可以组成几个独立的区域,假设该区域数为t,则需要增加的边即为t-1。
(3)为了实现(2)中所说,我们采用DFS(深度优先)最佳。
 
参考代码:
#include<stdio.h>
#include<string.h>

#define max 1001
int edge[max][max];
int visited[max];
int query[max];
int N; // the total number of cities
int M; // the number of remaining highways
int K; // the number of cities to be checked

void dfs(int t)
{
	visited[t] = 1;
	int i;
	for(i=1; i<=N; i++)
	{
		if(!visited[i] && edge[i][t] == 1)
			dfs(i);
	}
}



int main()
{	
	int i,j;
	int a,b;	
	scanf("%d%d%d",&N,&M,&K);
	for(i=0; i<M; i++)
	{
		scanf("%d%d",&a,&b);
		edge[a][b] = 1;
		edge[b][a] = 1;
	}
	int temp;
	int num;
	for(i=0; i<K; i++)
	{
		num = 0;
		scanf("%d",&temp);
		memset(visited,0,sizeof(visited));
		visited[temp] = 1;
		for(j=1; j<=N; j++)
		{
			if(visited[j] == 0)
			{				
				dfs(j);
				num ++;
			}
		}
		printf("%d\n",num-1);
	}

}

 


补充:软件开发 , C++ ,
CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,