当前位置:编程学习 > C/C++ >>

TOJ 2861 ZOJ 1086 Octal Fractions

Octal Fractions
时间限制(普通/Java):1000MS/3000MS     运行内存限制:65536KByte
描述
 
Fractions in octal (base 8) notation can be expressed exactly in decimal notation. For example, 0.75 in octal is 0.953125 (7/8 + 5/64) in decimal. All octal numbers of n digits to the right of the octal point can be expressed in no more than 3n decimal digits to the right of the decimal point. 
 
Write a program to convert octal numerals between 0 and 1, inclusive, into equivalent decimal numerals.
 
输入
 
The input to your program will consist of octal numbers, one per line, to be converted. Each input number has the form 0.d1d2d3 ... dk, where the di are octal digits (0..7). There is no limit on k.
 
输出
 
Your output will consist of a sequence of lines of the form 
 
 
0.d1d2d3 ... dk [8] = 0.D1D2D3 ... Dm [10]
 
 
where the left side is the input (in octal), and the right hand side the decimal (base 10) equivalent. There must be no trailing zeros, i.e. Dm is not equal to 0.
样例输入
 
0.75
0.0001
0.01234567
样例输出
 
0.75 [8] = 0.953125 [10]
0.0001 [8] = 0.000244140625 [10]
0.01234567 [8] = 0.020408093929290771484375 [10]
可以怎么做 0.75 = (5/8+7)/8
 
0.01234567 = (((7/8+6)/8)+5)/8....
 
模拟高精度就行
 
代码高队长提供
 
 
#include <stdio.h>  
#include <string.h>  
#include <string>  
#include <iostream>  
#include <algorithm>  
using namespace std;  
string s;  
char res[30000];  
int reslen;  
void js()  
{  
    int i,j,k,num=0;  
    for(i=0;;i++)  
    {  
        if(res[i]!=0)  
            num = num * 10 + res[i]-'0';  
        else   
            num = num * 10;  
        res[i]=num/8+'0';  
        num=num%8;  
        if(res[i+1]==0&&num==0) break;  
    }  
}  
int main()  
{  
    while(cin >> s)  
    {  
        reverse(s.begin(),s.end());  
        memset(res,0,sizeof(res));  
        int i,j,k;  
        for(i=0;s[i]!='.';i++)  
        {  
            res[0]=s[i];  
            js();  
        }  
        reverse(s.begin(),s.end());  
        cout << s <<" [8] = 0."<< res + 1 << " [10]"<<endl;  
    }  
    return 0;  
}  

 

 
补充:软件开发 , C++ ,
CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,