当前位置:编程学习 > C/C++ >>

Common Subsequence HDU dp

Common Subsequence 
 
Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 11   Accepted Submission(s) : 6
Problem Description
 
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 
 
 
 
 
Sample Input
abcfbc abfcab
programming contest 
abcd mnp
 
 
 
Sample Output
4
2
0
 [cpp] 
<SPAN style="FONT-SIZE: 14px">#include<cstdio>  
#include<cstring>   
using namespace std;  
int dp[1001][1001];  
int main()  
{  
    char pre[1001];  
    char pos[1001];  
    while(scanf("%s%s",pre,pos)!=EOF)  
    {  
        memset(dp,0,sizeof(dp));  
        int l1=strlen(pre);  
        int l2=strlen(pos);  
        for(int i=0; i<l1; i++)  
        {  
            for(int j=0; j<l2; j++)  
            {  
                if(pre[i]==pos[j])  
                    dp[i+1][j+1]=dp[i][j]+1;  
                else  if(dp[i+1][j]>dp[i][j+1])  
                    dp[i+1][j+1]=dp[i+1][j];  
                else  
                    dp[i+1][j+1]=dp[i][j+1];  
            }  
        }  
        printf("%d\n",dp[l1][l2]);  
    }  
    return 0;  
}  
</SPAN>  
 
#include<cstdio>
#include<cstring>
using namespace std;
int dp[1001][1001];
int main()
{
    char pre[1001];
    char pos[1001];
    while(scanf("%s%s",pre,pos)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        int l1=strlen(pre);
        int l2=strlen(pos);
        for(int i=0; i<l1; i++)
        {
            for(int j=0; j<l2; j++)
            {
                if(pre[i]==pos[j])
                    dp[i+1][j+1]=dp[i][j]+1;
                else  if(dp[i+1][j]>dp[i][j+1])
                    dp[i+1][j+1]=dp[i+1][j];
                elsewww.zzzyk.com
                    dp[i+1][j+1]=dp[i][j+1];
            }
        }
        printf("%d\n",dp[l1][l2]);
    }
    return 0;
}
 
 
 
 
 
补充:软件开发 , C++ ,
CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,