当前位置:编程学习 > C/C++ >>

10167 - Birthday Cake


 Problem G. Birthday Cake
Background
Lucy and Lily are twins. Today is their birthday. Mother buys a birthday cake for them.Now we put the cake onto a Descartes coordinate. Its center is at (0,0), and the cake's length of radius is 100.

 

There are 2N (N is a integer, 1<=N<=50) cherries on the cake. Mother wants to cut the cake into two halves with a knife (of course a beeline). The twins would like to be treated fairly, that means, the shape of the two halves must be the same (that means the beeline must go through the center of the cake) , and each half must have N cherrie(s). Can you help her?

Note: the coordinate of a cherry (x , y) are two integers. You must give the line as form two integers A,B(stands for Ax+By=0), each number in the range [-500,500]. Cherries are not allowed lying on the beeline. For each dataset there is at least one solution.

Input
The input file contains several scenarios. Each of them consists of 2 parts: The first part consists of a line with a number N, the second part consists of 2N lines, each line has two number, meaning (x,y) .There is only one space between two border numbers. The input file is ended with N=0.
Output
For each scenario, print a line containing two numbers A and B. There should be a space between them. If there are many solutions, you can only print one of them.
Sample Input
2
-20 20
-30 20
-10 -50
10 -5
0
Sample Output
0 1
以前这个题目还不会做,现在真正静下心来看还是很容易的
[cpp] 
#include <iostream> 
#include <cmath> 
using namespace std; 
int a[100][2]; 
int main() 

    double A,B,s; 
    int i,j,n,m,t,s1; 
    while(cin>>n) 
    { 
        if(n==0) 
        { 
            break; 
        } 
        for(i=0;i<=2*n-1;i++) 
        { 
            cin>>a[i][0]>>a[i][1]; 
        } 
        for(A=-500;A<=500;A++) 
        { 
            for(B=-500;B<=500;B++) 
            { 
                if(A!=0&&B!=0) 
                { 
                    s1=0; 
                    for(i=0;i<=2*n-1;i++) 
                    { 
                       s=A*a[i][0]+B*(a[i][1]); 
                       if(fabs(s)<=1e-7) 
                       { 
                           break; 
                       }else if(s>0) 
                       { 
                           s1++; 
                       } 
                    } 
                    if(i==2*n&&s1==n) 
                    { 
                        break; 
                    } 
                }else if(A==0&&B!=0) 
                { 
                    s1=0; 
                    for(i=0;i<=2*n-1;i++) 
                    { 
                        if(fabs(a[i][1])<=1e-7) 
                        { 
                            break; 
                        }else if(a[i][1]>0) 
                        { 
                            s1++; 
                        } 
                    } 
                    if(i==2*n&&s1==n) 
                    { 
                        break; 
        &n

补充:软件开发 , C++ ,
CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,