当前位置:编程学习 > C/C++ >>

hdu4288 Coder

Coder
Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2226    Accepted Submission(s): 907
 
 
Problem Description
  In mathematics and computer science, an algorithm describes a set of procedures or instructions that define a procedure. The term has become increasing popular since the advent of cheap and reliable computers. Many companies now employ a single coder to write an algorithm that will replace many other employees. An added benefit to the employer is that the coder will also become redundant once their work is done. 1
  You are now the signle coder, and have been assigned a new task writing code, since your boss would like to replace many other employees (and you when you become redundant once your task is complete).
Your code should be able to complete a task to replace these employees who do nothing all day but eating: make the digest sum.
  By saying “digest sum” we study some properties of data. For the sake of simplicity, our data is a set of integers. Your code should give response to following operations:
  1. add x – add the element x to the set;
  2. del x – remove the element x from the set;
  3. sum – find the digest sum of the set. The digest sum should be understood by
 
 
  where the set S is written as {a1, a2, ... , ak} satisfying a1 < a2 < a3 < ... < ak 
  Can you complete this task (and be then fired)?
------------------------------------------------------------------------------
1 See http://uncyclopedia.wikia.com/wiki/Algorithm
 
 
Input
  There’re several test cases.
  In each test case, the first line contains one integer N ( 1 <= N <= 105 ), the number of operations to process.
  Then following is n lines, each one containing one of three operations: “add x” or “del x” or “sum”.
  You may assume that 1 <= x <= 109.
  Please see the sample for detailed format.
  For any “add x” it is guaranteed that x is not currently in the set just before this operation.
  For any “del x” it is guaranteed that x must currently be in the set just before this operation.
  Please process until EOF (End Of File).
 
 
Output
  For each operation “sum” please print one line containing exactly one integer denoting the digest sum of the current set. Print 0 if the set is empty.
 
 
Sample Input
9
add 1
add 2
add 3
add 4
add 5
sum
add 6
del 3
sum
6
add 1
add 3
add 5
add 7
add 9
sum
 
 
Sample Output
3
4
5
Hint
C++ maybe run faster than G++ in this problem.
 
 
 
Source
2012 ACM/ICPC Asia Regional Chengdu Online
 
 
Recommend
liuyiding
线段树,对于这题,sum要用int64 ,这一点,我错了好几次, 这题要用线段树,是很显的啦,首先,我们用cnt保存这个区间上的结点的个数,用sum来保存,这个区间上的所有的mod i的和,这样,我们可以得到维护
 
l[num].sum[i]=l[lson].sum[i]+l[rson].sum[((i-l[lson].cnt)%5+5)%5]; 

 

 
 
处理的时候,先要离线化,再用一个二分就好了!  

 

 
 
#include <stdio.h>  
#include <string.h>  
#include <iostream>  
#include <algorithm>  
#define lson (num<<1)  
#define rson (num<<1|1)  
#define N 100050  
using namespace std;  
struct node {  
    int cnt;  
    __int64 sum[5];  
}l[N*20];  
char str[N][10];int p[N],q[N],pq[N],no[N],ans;  
bool cmp(int a,int b){return p[a]<p[b];}  
bool cmp1(int a,int b){return a<b;}  
int find(int goal)  
{  
    int s,e,mid;  
    s=0,e=ans;  
    while(s<=e)  
    {  
        mid=(s+e)>>1;  
        if(no[mid]==goal)  
        return mid;  
        else if(no[mid]>goal)  
        e=mid;  
        else if(no[mid]<goal)  
        s=mid;  
    }  
}  
void build(int num,int s,int e)  
{  
    l[num].cnt=0;  
    for(int i=0;i<5;i++)  
    l[num].sum[i]=0;  
    if(s>=e)  
    return;  
    int mid=(s+e)>>1;  
    build(lson,s,mid);  
    build(rson,mid+1,e);  
}  
int update(int num,int s,int e,int pos,int color,int k)  
{  
    if(s>=e)  
    {  
       l[num].cnt=color;  
       l[num].sum[0]=color*k;  
       return 1;  
    }  
    int mid=(s+e)>>1;  
    if(pos<=mid)  
    update(lson,s,mid,pos,color,k);  
    else if(pos>mid)  
    update(rson,mid+1,e,pos,color,k);  
    l[num].cnt=l[lson].cnt+l[rson].cnt;  
    for(int i=0;i<5;i++)  
    {  
        l[num].sum[i]=l[lson].sum[i]+l[rson].sum[((i-l[lson].cnt)%5+5)%5];  
    }  
}  
int main ()  
{  
    int n,i;  
    while(scanf("%d",&n)!=EOF)  
    {  
        for(ans=0,i=0;i<n;i++)  
        {  
            scanf("%s",&str[i]);  
            if(str[i][0]=='a')  
            {  
                scanf("%d",&p[i]);  
                no[ans]=p[i];  
                q[ans++]=i;  
            }  
            else if(str[i][0]=='d')  
            {  
                scanf("%d",&p[i]);  
            }  
        }  
        sort(q,q+ans,cmp);  
        sort(no,no+ans,cmp1);  
        build(1,1,ans);  
        for(i=0;i<ans;i++)  
        pq[q[i]]=i;  
        for(i=0;i<n;i++)  
        {  
            if(str[i][0]=='a')  
            {  
                update(1,1,ans,pq[i]+1,1,p[i]);  
            }  
            else if(str[i][0]=='d')  
            {  
               int pos=find(p[i]);  
                update(1,1,ans,pos+1,0,p[i]);  
            }  
            else if(str[i][0]=='s')  
            {  
                printf("%I64d\n",l[1].sum[2]);  
            }  
        }  
    }  
    return 0;  
}  

 


补充:软件开发 , C++ ,
CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,