当前位置:编程问答 > Unix/Linux >

ORA-39700: database must be opened with UPGRADE option解决

ORA-39700: database must be opened with UPGRADE option解决
 
1. 错误
操作系统和数据库都是服务提供商安装的,过了几个月才想起要用这个数据库,启动时出现如下错误。  www.zzzyk.com  
SQL> startup
ORACLE instance started.
 
Total System Global Area 4932501504 bytes
Fixed Size                  2103096 bytes
Variable Size             889194696 bytes
Database Buffers         4026531840 bytes
Redo Buffers               14671872 bytes
Database mounted.
ORA-01092: ORACLE instance terminated. Disconnection forced
 
2. 查看alert.log
 
ORA-00704: bootstrap process failure
ORA-39700: database must be opened with UPGRADE option
 
3. 查看数据库版本为:10.2.0.5.0,应该是他们做过数据库的升级而没有执行这个脚本造成的
$ORACLE_HOME\rdbms\admin\catupgrd.sql;
 
4.处理过程很简单
startup upgrade;
@$ORACLE_HOME\rdbms\admin\catupgrd.sql;
@$ORACLE_HOME/rdbms/admin/utlrp.sql;  --重新编译失效的object,跟这个问题本身关系不大
重启数据库
shutdwon immediate;
startup
ok
 
CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,