当前位置:编程学习 > C/C++ >>

UVa10004 Bicoloring(二分图判定)

Bicoloring 
In 1976 the ``Four Color Map Theorem" was proven with the assistance of a computer. This theorem states that every map can be colored using only four colors, in such a way that no region is colored using the same color as a neighbor region.
Here you are asked to solve a simpler similar problem. You have to decide whether a given arbitrary connected graph can be bicolored. That is, if one can assign colors (from a palette of two) to the nodes in such a way that no two adjacent nodes have the same color. To simplify the problem you can assume:
 
 
no node will have an edge to itself.
the graph is nondirected. That is, if a node a is said to be connected to a node b, then you must assume that b is connected to a.
the graph will be strongly connected. That is, there will be at least one path from any node to any other node.
Input 
 
 
The input consists of several test cases. Each test case starts with a line containing the number n ( 1 < n < 200) of different nodes. The second line contains the number of edges l. After this, l lines will follow, each containing two numbers that specify an edge between the two nodes that they represent. A node in the graph will be labeled using a number a (  $0 \le a < n$).
An input with n = 0 will mark the end of the input and is not to be processed.
 
 
Output 
 
 
You have to decide whether the input graph can be bicolored or not, and print it as shown below.
 
Sample Input 
3
3
0 1
1 2
2 0
9
8
0 1
0 2
0 3
0 4
0 5
0 6
0 7
0 8
0
 
Sample Output 
NOT BICOLORABLE.
BICOLORABLE.
 
code:
#include <iostream>  
#include <cstdio>  
#include <cstring>  
#include <vector>  
  
using namespace std;  
  
const int maxn = 200 + 10;  
vector<int> G[maxn];  
int n, m;  
int color[maxn];  
  
bool dfs(int v, int c)  
{  
    color[v] = c; //把顶点v染成颜色c  
    for(int i=0; i< G[v].size(); ++i) {  
        //如果相邻的顶点同色,则返回false  
        if(color[G[v][i]] == c) return false;  
        //如果相邻的顶点还没有被染色,则染成-c  
        if(color[G[v][i]] == 0 && !dfs(G[v][i], -c)) return false;  
    }  
    //如果所有顶点都染过色了,则返回true  
    return true;  
}  
void solve()  
{  
    for(int i=0; i<n; ++i) {  
        if(color[i] == 0) {  
            //如果顶点i还没被染色,则染成1  
            if(!dfs(i,1)) {  
                printf("NOT BICOLORABLE.\n");  
                return ;  
            }  
        }  
    }  
    printf("BICOLORABLE.\n");  
}  
  
int main()  
{  
    int i, x, y;  
    while(scanf("%d",&n),n) {  
        scanf("%d",&m);  
        memset(color, 0, sizeof color );  
        for(i=0; i<=n; ++i) G[i].clear();  
        for(i=0; i<m; ++i) {  
            scanf("%d%d",&x,&y);  
            G[x].push_back(y);  
            G[y].push_back(x);  
        }  
        solve();  
    }  
    return 0;  
}  
 
补充:软件开发 , C++ ,
CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,