当前位置:编程学习 > C/C++ >>

题目1005:Graduate Admission

时间限制:1 秒
内存限制:32 兆
特殊判题:否
提交:3168
解决:872
题目描述:
    It is said that in 2011, there are about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.
    Each applicant will have to provide two grades: the national entrance exam grade GE, and the interview grade GI. The final grade of an applicant is (GE + GI) / 2. The admission rules are:

    • The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.
    • If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade GE. If still tied, their ranks must be the same.
    • Each applicant may have K choices and the admission will be done according to his/her choices: if according to the rank list, it is one's turn to be admitted; and if the quota of one's most preferred shcool is not exceeded, then one will be admitted to this school, or one's other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.
    • If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.

输入:
    Each input file may contain more thanone test case.
    Each case starts with a line containing three positive integers: N (≤40,000), the total number of applicants; M (≤100), the total number of graduate schools; and K (≤5), the number of choices an applicant may have.
    In the next line, separated by a space, there are M positive integers. The i-th integer is the quota of the i-th graduate school respectively.
    Then N lines follow, each contains 2+K integers separated by a space. The first 2 integers are the applicant's GE and GI, respectively. The next K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M-1, and the applicants are numbered from 0 to N-1.

输出:
    For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants' numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.

样例输入:
11 6 3
2 1 2 2 2 3
100 100 0 1 2
60 60 2 3 5
100 90 0 3 4
90 100 1 2 0
90 90 5 1 3
80 90 1 0 2
80 80 0 1 2
80 80 0 1 2
80 70 1 3 2
70 80 1 2 3
100 100 0 2 4样例输出:
0 10
3
5 6 7
2 8

1 4来源:
2011年浙江大学计算机及软件工程研究生机试真题
code:

[cpp]
#include <iostream>  
#include <cstdio>  
#include <algorithm>  
#include <cstring>  
using namespace std; 
 
struct Student  

    int rank; 
    int ge; 
    int gi; 
    int choice[5]; 
}student[40001]; 
 
struct School 

    int number; 
    int sequence[40002]; 
    int cn; 
}school[101]; 
 
bool comp (Student a, Student b) 

    if ((a.ge+a.gi)!=(b.ge+b.gi)) 
        return (a.ge+a.gi) > (b.ge+b.gi); 
    else 
        return a.ge > b.ge; 

 
int main() 

 
    int n,m,k; 
    int i,j; 
    while (scanf ("%d%d%d",&n,&m,&k)!=EOF) 
    { 
        memset(student,0,sizeof(student)); 
        memset(school,0,sizeof(school)); 
        for (i=0;i<m;i++) 
        { 
            scanf ("%d",&school[i].number); 
        } 
         
        for (i=0;i<n;i++) 
        { 
            scanf ("%d%d",&student[i].ge,&student[i].gi); 
            student[i].rank=i; 
            for (j=0;j<k;j++) 
            { 
                scanf("%d",&student[i].choice[j]); 
            } 
        } 
        sort(student,student+n,comp); 
         
        for (i=0;i<n;i++) 
        { 
            for (j=0;j<k;j++) 
            { 
                if (school[student[i].choice[j]].number>0) 
                { 
                    school[student[i].choice[j]].number--; 
                    school[student[i].choice[j]].sequence[school[student[i].choice[j]].cn++]=student[i].rank; 
                    if (student[i+1].ge==student[i].ge && student[i+1].gi==student[i].gi&&school[student[i].choice[j]].number==0) 
                        school[student[i].choice[j]].sequence[school[student[i].choice[j]].cn++]=student[i+1].rank; 
                    break; 
                } 
            } 
        } 
  &nb

补充:软件开发 , C++ ,
CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,