当前位置:编程学习 > JAVA >>

HDU-1042 高精 java

N!
Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 41798    Accepted Submission(s): 11627


Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!

 

Input
One N in one line, process to the end of file.

 

Output
For each N, output N! in one line.

 

Sample Input
1
2
3

Sample Output
1
2
6
用java写高精度比较靠谱。
[java]
package lixiangmao; 
 
import java.math.BigInteger; 
import java.util.Scanner; 
 
public class HDU1042{   
    public static void main(String[] argc)   
    {   
        Scanner cin = new Scanner(System.in);   
        BigInteger a,n,i;   
        while(true)   
        {   
            a = cin.nextBigInteger();   
            n = BigInteger.ONE;   
            for(i=BigInteger.ONE; i.compareTo(a) <= 0; i = i.add(BigInteger.ONE))   
                n = n.multiply(i);   
            System.out.println(n);   
        }   
    }   
}   
         

package lixiangmao;

import java.math.BigInteger;
import java.util.Scanner;

public class HDU1042{ 
    public static void main(String[] argc) 
    { 
        Scanner cin = new Scanner(System.in); 
        BigInteger a,n,i; 
        while(true) 
        { 
            a = cin.nextBigInteger(); 
            n = BigInteger.ONE; 
            for(i=BigInteger.ONE; i.compareTo(a) <= 0; i = i.add(BigInteger.ONE)) 
                n = n.multiply(i); 
            System.out.println(n); 
        } 
    } 

  

 

补充:软件开发 , Java ,
CopyRight © 2022 站长资源库 编程知识问答 zzzyk.com All Rights Reserved
部分文章来自网络,