当前位置:编程学习 > C/C++ >>

HDU1425:sort

Problem Description
给你n个整数,请按从大到小的顺序输出其中前m大的数。
 
 
Input
每组测试数据有两行,第一行有两个数n,m(0<n,m<1000000),第二行包含n个各不相同,且都处于区间[-500000,500000]的整数。
 
 
Output
对每组测试数据按从大到小的顺序输出前m大的数。
 
 
Sample Input
5 3 www.zzzyk.com
3 -35 92 213 -644
 
 
Sample Output
213 92 3
 
Hint
Hint
 
请用VC/VC++提交
 
 
 
 
//这里不能用cin和cout进行输入输出,会超时
 
[cpp]  
#include <iostream>  
#include <cstdio>  
#include <algorithm>  
using namespace std;  
  
bool cmp(int x,int y)  
{  
    return x>y;  
}  
  
int a[1000000];  
  
int main()  
{  
    int n,k;  
    while(~scanf("%d%d",&n,&k))  
    {  
        for(int i = 0;i<n;i++)  
        scanf("%d",&a[i]);  
        sort(a,a+n,cmp);  
        printf("%d",a[0]);  
        for(int i = 1;i<k;i++)  
        printf(" %d",a[i]);  
        printf("\n");  
    }  
  
    return 0;  
}  
 
 
补充:软件开发 , C++ ,
CopyRight © 2022 站长资源库 编程知识问答 zzzyk.com All Rights Reserved
部分文章来自网络,