POJ 3080 Blue Jeans
Blue JeansTime Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8880 Accepted: 3734
Description
The Genographic Project is a research partnership between IBM and The National Geographic Society that is 易做图yzing DNA from hundreds of thousands of contributors to map how the Earth was populated.
As an IBM researcher, you have been tasked with writing a program that will find commonalities amongst given snippets of DNA that can be correlated with individual survey information to identify new genetic markers.
A DNA base sequence is noted by listing the nitrogen bases in the order in which they are found in the molecule. There are four bases: adenine (A), thymine (T), guanine (G), and cytosine (C). A 6-base DNA sequence could be represented as TAGACC.
Given a set of DNA base sequences, determine the longest series of bases that occurs in all of the sequences.
Input
Input to this problem will begin with a line containing a single integer n indicating the number of datasets. Each dataset consists of the following components:
A single positive integer m (2 <= m <= 10) indicating the number of base sequences in this dataset.
m lines each containing a single base sequence consisting of 60 bases.
Output
For each dataset in the input, output the longest base subsequence common to all of the given base sequences. If the longest common subsequence is less than three bases in length, display the string "no significant commonalities" instead. If multiple subsequences of the same longest length exist, output only the subsequence that comes first in alphabetical order.
Sample Input
3
2
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
3
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
3
CATCATCATCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
ACATCATCATAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AACATCATCATTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT
Sample Output
no significant commonalities
AGATAC
CATCATCAT
Source
South Central USA 2006
考察点:KMP
任取一字符串,然后模拟各个字符串字串,对字符串字串,用kmp和其他的字符串比较有没有在其中。
[cpp]
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
char s1[50][100];
char s2[100];
char res[100];
int next[100];
int len;
int main()
{
int KMP(char s3[100],int l);
int i,j,n,m,s,t,x,sum,k;
bool find;
int l;
len=60;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
for(i=0;i<=n-1;i++)
{
scanf("%s",s1[i]);
}
find=false; sum=0;
for(i=0;i<=len-1;i++)
{
if((i+3)<=len)
{
for(l=3;i+l<=len;l++)
{
x=0;
for(j=0;j<=l-1;j++)
{
s2[j]=s1[0][j+i];
}
s2[j]='\0';
for(j=1;j<=n-1;j++)
{
k=KMP(s1[j],l);
if(!k)
{
break;
}
}
if(j!=n)
{
break;
}else
{
find=true;
if(sum<l)
{
sum=l;
strcpy(res,s2);
}else if(sum==l)
{
if(strcmp(res,s2)>0)
{
strcpy(res,s2);
}
}
}
}
补充:软件开发 , C++ ,