hdu 3501 数论 与n不互质的数的和
Calculation 2
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1241 Accepted Submission(s): 518
Problem Description
Given a positive integer N, your task is to calculate the sum of the positive integers less than N which are not coprime to N. A is said to be coprime to B if A, B share no common positive divisors except 1.
Input
For each test case, there is a line containing a positive integer N(1 ≤ N ≤ 1000000000). A line containing a single 0 follows the last test case.
Output
For each test case, you should print the sum module 1000000007 in a line.
Sample Input
3
4
0
Sample Output
0
2
Author
GTmac
Source
2010 ACM-ICPC Multi-University Training Contest(7)——Host by HIT
题意:
输入n 计算比n小的数中 和n不互质的数的和 %1000000007
[cpp]
/* if 易做图(n,i)==1 then 易做图(n,n-i)==1
所以 那么对于n有phi(n)(欧拉函数)个小于n的数与n互质
由上面的公式可以知道 其中一个若为i则存在一个为n-i
那么2者之和为n 这样的一共有phi(n)/2对
故与n互质的所有数的和为 n*phi(n)/2
那么与n不互质的 数就是(1+n-1)*(n-1)/2-n*phi(n)/2
*/
#include<stdio.h>
#include<math.h>
#define mod 1000000007
__int64 get_phi(__int64 x)// 就是公式
{
__int64 i, res=x;
for (i = 2; i <(__int64)sqrt(x * 1.0) + 1; i++)
if(x%i==0)
{
res = res / (__int64)i * (i - 1);
while (x % i == 0) x /= i; // 保证i一定是素数
}
if (x > 1) res = res / (__int64)x * (x - 1);//这里小心别溢出了
return res;
}
int main()
{
__int64 n,ans;
while(scanf("%I64d",&n)!=EOF)
{
if(!n) break;
ans=((__int64)(1+n-1)*(n-1)/2-(__int64)n*get_phi(n)/2)%mod;//不能先除2再乘
printf("%I64d\n",ans%mod);
}
return 0;
}
补充:软件开发 , C++ ,