当前位置:编程学习 > C/C++ >>

UVA 10020 Minimal coverage(贪心 + 区间覆盖问题)

 Minimal coverage 

 

The Problem
Given several segments of line (int the X axis) with coordinates [Li,Ri]. You are to choose the minimal amount of them, such they would completely cover the segment [0,M].


The Input

The first line is the number of test cases, followed by a blank line.

Each test case in the input should contains an integer M(1<=M<=5000), followed by pairs "Li Ri"(|Li|, |Ri|<=50000, i<=100000), each on a separate line. Each test case of input is terminated by pair "0 0".

Each test case will be separated by a single line.


The Output
For each test case, in the first line of output your programm should print the minimal number of line segments which can cover segment [0,M]. In the following lines, the coordinates of segments, sorted by their left end (Li), should be printed in the same format as in the input. Pair "0 0" should not be printed. If [0,M] can not be covered by given line segments, your programm should print "0"(without quotes).

Print a blank line between the outputs for two consecutive test cases.


Sample Input

2

1
-1 0
-5 -3
2 5
0 0

1
-1 0
0 1
0 0

Sample Output

0

1
0 1


题意:给定一个M,和一些区间[Li,Ri]。。要选出几个区间能完全覆盖住[0,M]区间。要求数量最少。。如果不能覆盖输出0.

思路:贪心的思想。。把区间按Ri从大到小排序。 然后遇到一个满足的[Li,Ri],就更新缩小区间。。直到完全覆盖。


注意[Li,Ri]只有满足Li小于等于且Ri大于当前覆盖区间左端这个条件。才能选中。


代码:


 

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int t;
int start, end, qn, outn;
struct M {
    int start;
    int end;
} q[100005], out[100005];

int cmp (M a, M b) {//按最大能覆盖到排序
    return a.end > b.end;
}
int main() {
    scanf("%d", &t);
    while (t --) {
	qn = 0; outn = 0; start = 0;
	scanf("%d", &end);
	while (~scanf("%d%d", &q[qn].start, &q[qn].end) && q[qn].start + q[qn].end) {
	    qn ++;
	}
	sort(q, q + qn, cmp);
	while (start < end) {
	    int i;
	    for (i = 0; i < qn; i ++) {
		if (q[i].start <= start && q[i].end > start) {
		    start = q[i].end;//更新区间
		    out[outn ++] = q[i];
		    break;
		}
	    }
	    if (i == qn) break;//如果没有一个满足条件的区间,直接结束。
	}
	if (start < end) printf("0\n");
	else {
	    printf("%d\n", outn);
	    for (int i = 0; i < outn; i ++)
		printf("%d %d\n", out[i].start, out[i].end);
	}
	if (t) printf("\n");
    }
    return 0;
}

 

补充:软件开发 , C++ ,
CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,