POJ 2031 Building a Space Station
Building a Space StationTime Limit: 1000MS Memory Limit: 30000K
Total Submissions: 3192 Accepted: 1664
Description
You are a member of the space station engineering team, and are assigned a task in the construction process of the station. You are expected to write a computer program to complete the task.
The space station is made up with a number of units, called cells. All cells are sphere-shaped, but their sizes are not necessarily uniform. Each cell is fixed at its predetermined position shortly after the station is successfully put into its orbit. It is quite strange that two cells may be touching each other, or even may be overlapping. In an extreme case, a cell may be totally enclosing another one. I do not know how such arrangements are possible.
All the cells must be connected, since crew members should be able to walk from any cell to any other cell. They can walk from a cell A to another cell B, if, (1) A and B are touching each other or overlapping, (2) A and B are connected by a `corridor', or (3) there is a cell C such that walking from A to C, and also from B to C are both possible. Note that the condition (3) should be interpreted transitively.
You are expected to design a configuration, namely, which pairs of cells are to be connected with corridors. There is some freedom in the corridor configuration. For example, if there are three cells A, B and C, not touching nor overlapping each other, at least three plans are possible in order to connect all three cells. The first is to build corridors A-B and A-C, the second B-C and B-A, the third C-A and C-B. The cost of building a corridor is proportional to its length. Therefore, you should choose a plan with the shortest total length of the corridors.
You can ignore the width of a corridor. A corridor is built between points on two cells' su易做图ces. It can be made arbitrarily long, but of course the shortest one is chosen. Even if two corridors A-B and C-D intersect in space, they are not considered to form a connection path between (for example) A and C. In other words, you may consider that two corridors never intersect.
Input
The input consists of multiple data sets. Each data set is given in the following format.
n
x1 y1 z1 r1
x2 y2 z2 r2
...
xn yn zn rn
The first line of a data set contains an integer n, which is the number of cells. n is positive, and does not exceed 100.
The following n lines are descriptions of cells. Four values in a line are x-, y- and z-coordinates of the center, and radius (called r in the rest of the problem) of the sphere, in this order. Each value is given by a decimal fraction, with 3 digits after the decimal point. Values are separated by a space character.
Each of x, y, z and r is positive and is less than 100.0.
The end of the input is indicated by a line containing a zero.
Output
For each data set, the shortest total length of the corridors should be printed, each in a separate line. The printed values should have 3 digits after the decimal point. They may not have an error greater than 0.001.
Note that if no corridors are necessary, that is, if all the cells are connected without corridors, the shortest total length of the corridors is 0.000.
Sample Input
3
10.000 10.000 50.000 10.000
40.000 10.000 50.000 10.000
40.000 40.000 50.000 10.000
2
30.000 30.000 30.000 20.000
40.000 40.000 40.000 20.000
5
5.729 15.143 3.996 25.837
6.013 14.372 4.818 10.671
80.115 63.292 84.477 15.120
64.095 80.924 70.029 14.881
39.472 85.116 71.369 5.553
0
Sample Output
20.000
0.000
73.834
Source
Japan 2003 Domestic
细细想来,这道题不就是求最小生成树嘛,但是在建图的时候刚开始把这题想复杂了,这个题只有相离的时候两个点距离才不为0,其他任何时候距离都为0。刚开始在处理内含的时候距离没有处理成0。 调试的时候发现这样样例过不了。
[cpp]
#include <stdio.h>
#include <string.h>
#include <math.h>
struct
{
double x,y,z,r;
}infor[110];
double a[110][110];
double b[110];
int INF=0x7fffffff;
int main()
{
int i,j,n,m,t,k;
double x,y,z,max,min;
double l1,l2,s;
while(scanf("%d",&n)!=EOF)
{
if(n==0)
{
break;
}
for(i=0;i<=n-1;i++)
{
a[i][i]=(double)INF;
scanf("%lf %lf %lf %lf",&infor[i].x,&infor[i].y,&infor[i].z,&infor[i].r);
}
for(i=0;i<=n-1;i++)
{
for(j=i+1;j<=n-1;j++)
{
x=infor[i].x-infor[j].x;
y=infor[i].y-infor[j].y;
z=infor[i].z-infor[j].z;
l1=sqrt(x*x+y*y+z*z);
l2=infor[i].r+infor[j].r;
if(l1-l2>0)
{
a[i][j]=l1-l2;
a[j][i]=l1-l2;
continue;
}
a[i][j]=a[j][i]=0;
}
}
for(i=0;i<=n-1;i++)
{
b[i]=a[0][i];
}
for(i=1,s=0;i<=n-1;i++)
{
min=(double)INF;
for(j=1;j<=n-1;j++)
{
补充:软件开发 , C++ ,
- 更多C/C++疑问解答:
- 关于c++的cout输出的问题。
- 在学校里学过C和C++,不过学的很一般,现在自学C#,会不会很难?
- 全国计算机二级C语言笔试题
- 已知某树有2个2度结点,3个3度结点,4个4度结点,问有几个叶子结点?
- c++数据结构内部排序问题,整数排序
- 2012九月计算机二级C语言全国题库,,急求急求
- 如果assert只有一个字符串作为参数,是什么意思呢?
- C语言中,哪些运算符具有左结合性,哪些具有右结合性,帮忙总结下,谢谢了!
- 为什么用结构体编写的程序输入是,0输不出来啊~~~
- 将IEEE—754的十六进制转化为十进制浮点类型,用C或C++都行,多谢各位大侠啊,非常感谢!
- 为什么这个程序求不出公式?
- 这个链表倒置的算法请大家分析下
- c语言函数库调用
- C语言unsigned int纠错
- C语言快排求解啊