当前位置:编程学习 > C/C++ >>

poj 3264 Balanced Lineup

Description
For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things 易做图, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.
Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.
Input
Line 1: Two space-separated integers, N and Q. 
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i 
Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.
Output
Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.
Sample Input
6 3
1
7
3
4
2
5
1 5
4 6
2 2
Sample Output
6
3
0
题解:线段树的简单题,使用两个数组记录,一个记录最大值,一个记录最小值即可...
代码:
 
#include <iostream>  
#include <cmath>  
#include <cstdio>  
#include <cstring>  
#define maxn 50010  
#define lson l,m,rt<<1  
#define rson m+1,r,rt<<1|1  
using namespace std;  
int MAX[maxn<<2],MIN[maxn<<2];  
  
  
void PushUP(int rt)  
{  
    MAX[rt]=max(MAX[rt<<1],MAX[rt<<1|1]);  
    MIN[rt]=min(MIN[rt<<1],MIN[rt<<1|1]);  
}  
  
void Build(int l,int r,int rt)  
{  
    if(l==r)  
    {  
        scanf("%d",&MAX[rt]);  
        MIN[rt]=MAX[rt];  
        return;  
    }  
    int m=(l+r)>>1;  
    Build(lson);  
    Build(rson);  
    PushUP(rt);  
}  
  
int Query(int L,int R,int l,int r,int rt,int t)  
{  
    if(L<=l&&R>=r)  
        if(t==1)  
            return MAX[rt];  
        else return MIN[rt];  
    int m=(l+r)>>1;  
  
    int ret=0;  
    if(t!=1) ret=1000000000;  
    if(L<=m)  
    {  
        if(t==1) ret=max(ret,Query(L,R,lson,t));  
        else ret=min(ret,Query(L,R,lson,t));  
    }  
    if(R>m)  
    {  
        if(t==1) ret=max(ret,Query(L,R,rson,t));  
        else ret=min(ret,Query(L,R,rson,t));  
    }  
    return ret;  
}  
  
int main()  
{  
    int N,M;  
    while(~scanf("%d%d",&N,&M))  
    {  
        memset(MAX,0,sizeof(MAX));  
        for(int i=0; i<=N; i++) MIN[i]=1000000000;  
        Build(1,N,1);  
        while(M--)  
        {  
            int a,b;  
            scanf("%d%d",&a,&b);  
            printf("%d\n",Query(a,b,1,N,1,1)-Query(a,b,1,N,1,2));  
        }  
    }  
    return 0;  
}  

 

 
补充:软件开发 , C++ ,
CopyRight © 2022 站长资源库 编程知识问答 zzzyk.com All Rights Reserved
部分文章来自网络,