当前位置:编程学习 > JAVA >>

Java程序练习-计算2的N次方

 

Period
时间限制: 3000ms内存限制: 65536kB
描述
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.
输入
The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the
number zero on it.
输出
For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
样例输入
3
aaa
12
aabaabaabaab
0
样例输出
Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4
参考代码
 
import java.io.BufferedReader; 
import java.io.IOException; 
import java.io.InputStreamReader; 
public class Main { 
    public static void main(String[] args) throws IOException { 
        BufferedReader cin = new BufferedReader(new InputStreamReader(System.in)); 
        int cases = 0; 
        while(true){ 
            int n = Integer.parseInt(cin.readLine()); 
            if(0 == n) 
                break; 
            String str = " "+cin.readLine(); 
            int next[] = new int[n + 2]; 
            int i = 1,j = 0; 
            next[1] = 0; 
            while(i <= n){ 
                if(str.charAt(i) == str.charAt(j)||j == 0){ 
                    i ++; 
                    j ++; 
                    next[i] = j; 
                }else{ 
                    j = next[j]; 
                } 
            } 
            System.out.println("Test case #"+ ++cases); 
            for(int k=2;k<=n;k++){ 
                if(k%((k+1)-next[k+1])==0){ 
                    int count=k /((k+1)-next[k+1]); 
                    if(count!=1) 
                        System.out.println(k+" "+count); 
                }   
            } 
            System.out.println(); 
        } 
    } 

 

摘自:冰非寒

补充:软件开发 , Java ,
CopyRight © 2022 站长资源库 编程知识问答 zzzyk.com All Rights Reserved
部分文章来自网络,