POJ 2661 Factstone Benchmark
Description
Amtel has announced that it will release a 128-bit computer chip by 2010, a 256-bit computer by 2020, and so on, continuing its strategy of doubling the word-size every ten years. (Amtel released a 64-bit computer in 2000, a 32-bit computer in 1990, a 16-bit computer in 1980, an 8-bit computer in 1970, and a 4-bit computer, its first, in 1960.)
Amtel will use a new benchmark - the Factstone - to advertise the vastly improved capacity of its new chips. The Factstone rating is defined to be the largest integer n such that n! can be represented as an unsigned integer in a computer word.
Given a year 1960 <= y <= 2160, what will be the Factstone rating of Amtel's most recently released chip?
Input
There are several test cases. For each test case, there is one line of input containing y. A line containing 0 follows the last test case.
Output
For each test case, output a line giving the Factstone rating.
Sample Input
1960
1981
0
Sample Output
3
8
由于这是高精度没法用普通方式计算阶乘,否则会TLE
可以用斯特林(Stirling)公式求解
斯特林(Stirling)公式:
[html]
#include <stdio.h>
int main()
{
int year;
int endflag;
int n;
double sum;
while(scanf("%d", &year),year)
{
endflag = 1<<((year - 1960) / 10 + 2);
n = 2;
sum = 0;
while(sum <= endflag)
{
sum += log(n) / log(2);
++n;
}
printf("%d\n", n - 2);
}
return 0;
}
作者;ultimater
补充:软件开发 , C++ ,