UVa 10954 - Add All
原题:
Yup!! The problem name reflects your task; just add a set of numbers. But you may feel yourselves condescended, to write a C/C++ program just to add a set of numbers. Such a problem will simply question your erudition. So, let’s add some flavor of ingenuity to it.
Addition operation requires cost now, and the cost is the summation of those two to be added. So, to add 1 and 10, you need a cost of 11.If you want to add 1, 2 and 3. There are several ways –
1 + 2 = 3, cost = 3
3 + 3 = 6, cost = 6
Total = 9
1 + 3 = 4, cost = 4
2 + 4 = 6, cost = 6
Total = 10
2 + 3 = 5, cost = 5
1 + 5 = 6, cost = 6
Total = 11
I hope you have understood already your mission, to add a set of integers so that the cost is minimal.
Input
Each test case will start with a positive number, N (2 ≤ N ≤ 5000) followed by N positive integers (all are less than 100000). Input is terminated by a case where the value of N is zero. This case should not be processed.
Output
For each case print the minimum total cost of addition in a single line.
样例输入:
3
1 2 3
4
1 2 3 4
0
样例输出:
9
19
题目大意:
有一些数字, 要把所有这些数字加起来求它们的总和。 没执行一次加法时,这次加法的结果就是一个花费。可以以任意的数序进行加法,所以不同的顺序花费不同的。求总花费最小是多少。
分析总结:
按照贪心的思路,为了让总花费最少,那么要使得每一次的花费最少,最终结果一定是最少的。
可以用优先队列,这样每次取出来用来相加的两个数一定是队列中最小的两个数,花费也是最少的。
代码:
[cpp]
/*
* UVa: 10954 - Add All
* Result: Accept
* Time: 0.024s
* Author: D_Double
*/
#include<cstdio>
#include<queue>
#define MAXN 5005
using namespace std;
priority_queue<long long, vector<long long>, greater<long long> >que;
int main(){
int N;
long long m;
while(scanf("%d",&N) && N){
while(!que.empty()) que.pop();
for(int i=0; i<N; ++i){
scanf("%lld",&m);
que.push(m);
}
long long sum=0, ans=0, a, b, t;
while(!que.empty()){
a=que.top();
que.pop();
if(que.empty()) break;
b=que.top();
que.pop();
sum=a+b;
ans += sum;
que.push(sum);
}
printf("%lld\n", ans);
}
return 0;
}
作者:shuangde800
补充:软件开发 , C++ ,