当前位置:编程学习 > C/C++ >>

杭电OJ 1083——courses(二分图的匹配问题!匈牙利算法解答)


Problem Description
Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

. every student in the committee represents a different course (a student can represent a course if he/she visits that course)

. each course has a representative in the committee

Your program should read sets of data from a text file. The first line of the input file contains the number of the data sets. Each data set is presented in the following format:

P N
Count1 Student1 1 Student1 2 ... Student1 Count1
Count2 Student2 1 Student2 2 ... Student2 Count2
......
CountP StudentP 1 StudentP 2 ... StudentP CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses . from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you'll find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.

There are no blank lines between consecutive sets of data. Input data are correct.

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

An example of program input and output:
 

Sample Input
2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1
 

Sample Output
YES
NO
 
问题不难!关键在于算法!这种题型属于二分图的匹配问题!用匈牙利算法来解答最好不过!关于匈牙利算法的描述,请看这里,讲的不能再好了,仔细看,会很有收获的! 
我花了几个小时,终于把这个算法弄懂了!很强大的算法!没想到离散数学竟然也这么重要!呵!
贴代码吧!
[cpp]
//现在弄到一个判断二分匹配的算法,仔细研究研究,很爽的! 
#include<iostream> 
using namespace std; 
const int Max=500; 
 
int g[Max][Max]; 
int linker[Max]; 
bool used[Max]; 
 
bool dfs(int u) 

    int v; 
    for(v=1;v<=g[0][1];v++) 
    { 
        if(g[u][v] && !used[v]) 
        { 
            used[v]=true; 
            if(linker[v]==-1 || dfs(linker[v])) 
            { 
                linker[v]=u; 
                return true; 
            } 
        } 
    } 
    return false; 

 
int hungary() 

    int res=0; 
    int u; 
    memset(linker,-1,sizeof(linker)); 
 
    for(u=1;u<=g[0][0];u++) 
    { 
        memset(used,0,sizeof(used)); 
        if(dfs(u)) res++; 
    } 
    return res; 

 
int main() 

    int cases; 
    cin>>cases; 
    while(cases--) 
    { 
        int num,m; 
        memset(g,0,sizeof(g)); 
        cin>>g[0][0]>>g[0][1]; 
        for(int i=1;i<=g[0][0];i++) 
        { 
            cin>>num; 
            for(int j=0;j<num;j++) 
            { 
                cin>>m; 
                g[i][m]=1; 
            } 
        } 
        if(hungary()!=g[0][0]) 
            cout<<"NO"<<endl; 
        else 
            cout<<"YES"<<endl; 
 
    } 
    return 0; 

补充:软件开发 , C++ ,
CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,