POJ 1936 All in All
All in All
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 23927 Accepted: 9581
Description
You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.
Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.
Input
The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.
Output
For each test case output "Yes", if s is a subsequence of t,otherwise output "No".
Sample Input
sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter
Sample Output
Yes
No
Yes
No
Source
Ulm Local 2002
一开始看到数据那么大,有点懵了,细想之下一一比对就行
[cpp]
#include <iostream>
#include <cstring>
using namespace std;
string s1,s2;
int main()
{
int i,j,n,m,s,t;
int l1,l2;
while(cin>>s1>>s2)
{
l1=s1.size();
l2=s2.size();
for(i=0,j=0;i<=l1-1,j<=l2-1;j++)
{
if(s1[i]==s2[j])
{
i++;
}
}
if(i==l1)
{
cout<<"Yes"<<endl;
}else
{
cout<<"No"<<endl;
}
}
return 0;
}
补充:软件开发 , C++ ,