当前位置:编程学习 > C/C++ >>

UVA 490 Rotating Sentences

Rotating Sentences

In ``Rotating Sentences,'' you are asked to rotate a series of input sentences 90 degrees clockwise. So instead of displaying the input sentences from left to right and top to bottom, your program will display them from top to bottom and right to left.


Input and Output
As input to your program, you will be given a maximum of 100 sentences, each not exceeding 100 characters long. Legal characters include: newline, space, any punctuation characters, digits, and lower case or upper case English letters. (NOTE: Tabs are not legal characters.)


The output of the program should have the last sentence printed out vertically in the leftmost column; the first sentence of the input would subsequently end up at the rightmost column.


Sample Input

Rene Decartes once said,
"I think, therefore I am."
Sample Output

"R
Ie
 n
te
h
iD
ne
kc
,a
 r
tt
he
es
r
eo
fn
oc
re
e
 s
Ia
 i
ad
m,
.
"     这是一道处理字符串的题目。将输入的字符串顺时针旋转90度以后输出。和矩阵的旋转差不多。


#include<stdio.h>
#include<string.h>
int main()
{
    int i,j,len,maxlen,k;
    char s[105][105];
    i=0;
    maxlen=0;
    memset(s,0,sizeof(s)); /*初始化*/
    while(gets(s[i])!=NULL)
    {
        len=strlen(s[i]);
        if(len>maxlen)  /*求最长的字符串长度*/
          maxlen=len;
		i++;
    }
    for(j=0;j<maxlen;j++)
    {
       for(k=i-1;k>=0;k--)
       {
           if(s[k][j]==0)
             printf(" ");
           else
             printf("%c",s[k][j]);
       }
       printf("\n");
    }
    return 0;
}

 

补充:软件开发 , C++ ,
CopyRight © 2022 站长资源库 编程知识问答 zzzyk.com All Rights Reserved
部分文章来自网络,