POJ 3267 The Cow Lexicon
The Cow Lexicon
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 6548 Accepted: 3021
Description
Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters 'a'..'z'. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said "browndcodw". As it turns out, the intended message was "browncow" and the two letter "d"s were noise from other parts of the barnyard.
The cows want you to help them decipher a received message (also containing only characters in the range 'a'..'z') of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.
Input
Line 1: Two space-separated integers, respectively: W and L
Line 2: L characters (followed by a newline, of course): the received message
Lines 3..W+2: The cows' dictionary, one word per line
Output
Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.
Sample Input
6 10
browndcodw
cow
milk
white
black
brown
farmer
Sample Output
2
Source
USACO 2007 February Silver
做这个题目的时候是一点思路没有,感觉用dp但是不会搞,所以直接看了一下解题报告
感觉这个挺好的
#include <iostream>
#include <string.h>
using namespace std;
int dp[400];
string s1[610];
string s2;
int min1;
int main()
{
int i,j,n,m,s,t;
int len,l,x,y;
cin>>n>>len;
cin>>s2;
for(i=1; i<=n; i++)
{
cin>>s1[i];
}
dp[len]=0;
for(i=len-1; i>=0; i--)
{
dp[i]=dp[i+1]+1;
for(j=1; j<=n; j++)
{
l=s1[j].size();
if(l<=(len-i)&&s2[i]==s1[j][0])
{
for(x=i,y=0; x<=len-1; x++)
{
if(s2[x]==s1[j][y])
{
y++;
}
if(y==l)
{
if(dp[i]>(dp[x+1]+(x+1)-i-l))
{
dp[i]=(dp[x+1]+(x+1)-i-l);
}
}
}
}
}
}
cout<<dp[0]<<endl;
return 0;
}
补充:软件开发 , C++ ,