当前位置:编程学习 > C/C++ >>

hdu 3664Permutation Counting(简单dp)

Permutation Counting
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1175    Accepted Submission(s): 589
 
 
Problem Description
Given a permutation a1, a2, … aN of {1, 2, …, N}, we define its E-value as the amount of elements where ai > i. For example, the E-value of permutation {1, 3, 2, 4} is 1, while the E-value of {4, 3, 2, 1} is 2. You are requested to find how many permutations of {1, 2, …, N} whose E-value is exactly k.
 
 
Input
There are several test cases, and one line for each case, which contains two integers, N and k. (1 <= N <= 1000, 0 <= k <= N). 
 
 
Output
Output one line for each case. For the answer may be quite huge, you need to output the answer module 1,000,000,007.
 
 
Sample Input
3 0
3 1
 
 
Sample Output
1
4
 
Hint
There is only one permutation with E-value 0: {1,2,3}, and there are four permutations with E-value 1: {1,3,2}, {2,1,3}, {3,1,2}, {3,2,1}
 
 
 
Source
2010 Asia Regional Harbin
#include<iostream>  
#include<cstring>  
#include<cstdio>  
using namespace std;  
long long mod = 1e9+7;  
long long ans[1002][1002];  
  
void presolve()  
{  
    int i,j;  
    for(i=1;i<=1000;i++)  
    {  
        ans[i][0]=1;  
        for(j=1;j<=1000;j++)  
            ans[i][j]=((1+j)*ans[i-1][j]+(i-j)*ans[i-1][j-1])%mod;  
    }  
}  
  
int main()  
{  
    presolve();  
    int n,k;  
    while(cin>>n>>k)  
        cout<<ans[n][k]<<endl;  
    return 0;  
}  

 

 
 
 
题目大意:给你一个n,代表有n个数,分别是1 2 3 .......n-1 n,如果这个数比这个数的位置大,那么t++,例如3个数,1 3 2那么t=1,因为a[2]>2,给你一个n,再给你一个k,问你这样使得t等于k的排列组合数是多少?
 
 解题思路:开始是自己写了前面四个,可以慢慢发现规律,设比它位置大的数为特殊数,f[i][j] 表示从1到i 特殊数为j 的排列数
(1) f[i-1][j]表示添加的第i 个数在第 i个位置,不改变特殊数的个数
(2) j*f[i-1][j] 将第i 个数和前面j 个特殊数数交换位置,依然不改变特殊数的个数
(3) (i-j)*f[i-1][j-1] 将第i 个数和前面 (i-j) 个非特殊数数交换位置可得到j 个特殊数
 
具体实现见代码。
 
题目地址:Permutation Counting
 
AC代码:
 
 
 
补充:软件开发 , C++ ,
CopyRight © 2022 站长资源库 编程知识问答 zzzyk.com All Rights Reserved
部分文章来自网络,