当前位置:编程学习 > C/C++ >>

c语言关于汉诺塔问题怎么求解

描述 汉诺塔(又称河内塔)问题是印度的一个古老的传说。开天辟地的神勃拉玛在一个庙里留下了三根金刚石的棒A、B和C,A上面套着n个圆的金片, 最大的一个在底下,其余一个比一个小,依次叠上去, 庙里的众僧不倦地把它们一个个地从A棒搬到C棒上,规定可利用中间的一根B棒作为帮助, 但每次只能搬一个, 而且大的不能放在小的上面。 僧侣们搬得汗流满面,可惜当n很大时这辈子恐怕就很搬了 聪明的你还有计算机帮你完成,你能写一个程序帮助僧侣们完成这辈子的夙愿吗? 输入 输入金片的个数n。这里的n<=10。 输出 输出搬动金片的全过程。格式见样例 样例输入 2 样例输出 Move disk 1 from A to B Move disk 2 from A to C Move disk 1 from B to C #include<stdio.h> int main() { void hanoi(int n,char one,char two,char three); int n; scanf("%d",&n); hanoi(n,'A','B','C'); } void hanoi(int n,char one,char two,char three) { void move(char n,char x,char y); if(n==1) move(1,one,three); else { hanoi(n-1,one,three,two); move(n,one,three); hanoi(n-1,two,one,three); } } void move(char n,char x,char y) { printf("Move disk %c from %c to %c\n",n,x,y); }问问我的代码该怎么改下才能输出正确答案那
答案:#include<stdio.h>
void move(int n,char x,char y);
void hanoi(int n,char one,char two,char three);
int main()
{
	int n;
	scanf("%d",&n);
	hanoi(n,'A','B','C');
}
void hanoi(int n,char one,char two,char three)
{
	if(n==1)
	move(1,one,three);
	else
	{
		hanoi(n-1,one,three,two);
		move(n,one,three);
		hanoi(n-1,two,one,three);
		
	}
}

void move(int n,char x,char y)
{
	printf("Move disk %d from %c to %c\n",n,x,y);
}
这样就行了,另外输入的数不能太大,最好10以内,要是超过64,有你受的,一会半会儿是计算不玩的。
其他:void move(char n,char x,char y);
void hanoi(int n,char one,char two,char three)
{
	if(n==1)
	move(1,one,three);
	else
	{
		hanoi(n-1,one,three,two);
		move(n,one,three);
		hanoi(n-1,two,one,three);
		
	}
}

void move(int n,char x,char y)
{
	printf("Move disk %d from %c to %c\n",n,x,y);
} 需要一个递归算法  网上可以搜到了 而且很多 希望采纳 谢谢了

上一个:C语言 编程 想为51芯片编以一小段‘等待响应程序’ 万分感谢
下一个:c语言基础问题

CopyRight © 2022 站长资源库 编程知识问答 zzzyk.com All Rights Reserved
部分文章来自网络,