当前位置:编程学习 > C/C++ >>

POJ 1731 Orders

Orders
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 8268 Accepted: 5168
Description
The stores manager has sorted all kinds of goods in an alphabetical order of their labels. All the kinds having labels starting with the same letter are stored in the same warehouse (i.e. in the same building) labelled with this letter. During the day the stores manager receives and books the orders of goods which are to be delivered from the store. Each order requires only one kind of goods. The stores manager processes the requests in the order of their booking.
 
You know in advance all the orders which will have to be processed by the stores manager today, but you do not know their booking order. Compute all possible ways of the visits of warehouses for the stores manager to settle all the demands piece after piece during the day.
Input
Input contains a single line with all labels of the requested goods (in random order). Each kind of goods is represented by the starting letter of its label. Only small letters of the English alphabet are used. The number of orders doesn't exceed 200.
Output
Output will contain all possible orderings in which the stores manager may visit his warehouses. Every warehouse is represented by a single small letter of the English alphabet -- the starting letter of the label of the goods. Each ordering of warehouses is written in the output file only once on a separate line and all the lines containing orderings have to be sorted in an alphabetical order (see the example). No output will exceed 2 megabytes.
Sample Input
bbjd
Sample Output
bbdj
bbjd
bdbj
bdjb
bjbd
bjdb
dbbj
dbjb
djbb
jbbd
jbdb
jdbb
Source
CEOI 1999
解题思路:会用STL的next_permutation函数即可。
[cpp]  
#include<iostream>  
#include<algorithm>  
#include<cstring>  
#include<cstdio>  
using namespace std;  
int main()   www.zzzyk.com
{  
    char a[210];  
    gets(a);  
    int l=strlen(a);  
    sort(a,a+l);  
    do  
    {  
        puts(a);  
    }  
    while(next_permutation(a,a+l));  
    return 0;  
}  
 
补充:软件开发 , C++ ,
CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,