当前位置:编程学习 > JAVA >>

算法笔记之 并查集入门 POJ 1611

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output

For each case, output the number of suspects in one line.
Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0Sample Output

4
1
1

并查集的介绍大家还是google吧,我只会贴代码,见谅啊~


[cpp]
#include <iostream>  
using namespace std; 
int father[30001]; //存储father index  
int group[30001]; //存储当前  集合的人数  
//初始化  
void init(int len) { 
    for (int i = 0; i <= len; i++){ 
        father[i] = i; 
        group[i] = 1; 
    } 

//查找i的最终father  
int find_set(int i){ 
    if(i != father[i]){ 
        father[i] = find_set(father[i]); //路径压缩  
    } 
    return father[i]; 

//合并两个点  
void join(int x,int y){ 
    int i = find_set(x); 
    int j = find_set(y); 
    if(i != j){ 
        father[i] = father[j]; 
        group[j] += group[i]; //合并时,由于最终father保存当前集合人数  
 
    } 

 
int main() { 
    int n,m,k; 
    while( cin >> n >> m){ 
        if(n == 0) 
            break; 
        init(n); //初始化  
        for(int i=0; i<m; i++){ 
            cin >> k; 
            int pre,cur; //前一个 和 当前  
            for(int j=0; j<k; j++){ 
                cin >> cur; 
                if(j) //第一个数不用管  
                    join(pre,cur); 
                pre =cur; 
            } 
        } 
//测试  
//      for(int i=0; i<n; i++)  
//          cout << father[i] << " ";  
//      cout << endl;  
//  
//      for(int i=0; i<n; i++)  
//                  cout << group[i] << " ";  
//              cout << endl;  
//  
//      cout << find_set(0) << endl;  
        cout << group[find_set(0)] << endl; 
    } 
    return 0; 

#include <iostream>
using namespace std;
int father[30001]; //存储father index
int group[30001]; //存储当前  集合的人数
//初始化
void init(int len) {
 for (int i = 0; i <= len; i++){
  father[i] = i;
  group[i] = 1;
 }
}
//查找i的最终father
int find_set(int i){
 if(i != father[i]){
  father[i] = find_set(father[i]); //路径压缩
 }
 return father[i];
}
//合并两个点
void join(int x,int y){
 int i = find_set(x);
 int j = find_set(y);
 if(i != j){
  father[i] = father[j];
  group[j] += group[i]; //合并时,由于最终father保存当前集合人数

 }
}

int main() {
 int n,m,k;
 while( cin >> n >> m){
  if(n == 0)
   break;
  init(n); //初始化
  for(int i=0; i<m; i++){
   cin >> k;
   int pre,cur; //前一个 和 当前
   for(int j=0; j<k; j++){
    cin >> cur;
    if(j) //第一个数不用管
     join(pre,cur);
    pre =cur;
   }
  }
//测试
//  for(int i=0; i<n; i++)
//   cout << father[i] << " ";
//  cout << endl;
//
//  for(int i=0; i<n; i++)
//     cout << group[i] << " ";
//    cout << endl;
//
//  cout << find_set(0) << endl;
  cout << group[find_set(0)] << endl;
 }
 return 0;
}
运行时间:47ms 太慢了。 优化一下 递归和输入输出:


[cpp] 
#include <stdio.h>  
int father[30001]; //存储father index  
int group[30001]; //存储当前  集合的人数  
补充:软件开发 , Java ,

CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,