POJ 3349 Snowflake Snow Snowflakes
Snowflake Snow SnowflakesTime Limit: 4000MS Memory Limit: 65536K
Total Submissions: 24826 Accepted: 6474
Description
You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.
Input
The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.
Output
If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.
Sample Input
2
1 2 3 4 5 6
4 3 2 1 6 5
Sample Output
Twin snowflakes found.
Source
CCC 2007
这道题目用哈希做,以前没用过,在用的时候犯糊涂,用哈希可能会有冲突,一定要有处理冲突的方法,这道题目在旋转的时候不必从六个点都进行正反方向的旋转,这样会超时,只要记录一下最小值,从最小值进行顺时针和逆时针的旋转就好了。注意最小值不止一个啊,可能有多个同时是最小值
[plain]
#include <stdio.h>
#include <string.h>
struct num
{
int pos;
int next;
} a[1000000];
int b[1000003],c[10],e[7],vex[200010][7];
int maxlen=1000003,s;
int check[1000003];
int main()
{
int i,j,n,m,t,sum,tag,x,y,min,k,u;
scanf("%d",&n);
tag=0;
s=1;
memset(b,-1,sizeof(b));
memset(check,0,sizeof(check));
for(i=1; i<=n; i++)
{
min=0x7fffffff;k=0;
for(j=1; j<=6; j++)
{
scanf("%d",&c[j]);
if(min>c[j])
{
min=c[j];k=0;
e[k++]=j;
}else if(min==c[j])
{
e[k++]=j;
}
}
if(!tag)
{
for(u=0;u<=k-1;u++)
{
j=e[u];
y=1;
sum=c[j]%maxlen;
vex[s][y++]=c[j];
for(x=j-1; x>=1; x--)
{
vex[s][y++]=c[x];
sum=(sum*10%maxlen+c[x]%maxlen)%maxlen;
}
for(x=6; x>=j+1; x--)
{
vex[s][y++]=c[x];
sum=(sum*10%maxlen+c[x]%maxlen)%maxlen;
}
if(!check[sum])
{
check[sum]=1;
a[s].pos=s;
a[s].next=b[sum];
b[sum]=s;
s++;
}
else
{
for(x=b[sum]; x!=-1; x=a[x].next)
{
for(y=1; y<=6; y++)
{
if(vex[s][y]!=vex[a[x].pos][y])
{
break;
}
}
if(y==7)
{
break;
}
&nbs
补充:软件开发 , C++ ,
上一个:指针引用
下一个:More Effective C++读书笔记
- 更多C/C++疑问解答:
- 关于c++的cout输出的问题。
- 在学校里学过C和C++,不过学的很一般,现在自学C#,会不会很难?
- 全国计算机二级C语言笔试题
- 已知某树有2个2度结点,3个3度结点,4个4度结点,问有几个叶子结点?
- c++数据结构内部排序问题,整数排序
- 2012九月计算机二级C语言全国题库,,急求急求
- 如果assert只有一个字符串作为参数,是什么意思呢?
- C语言中,哪些运算符具有左结合性,哪些具有右结合性,帮忙总结下,谢谢了!
- 为什么用结构体编写的程序输入是,0输不出来啊~~~
- 将IEEE—754的十六进制转化为十进制浮点类型,用C或C++都行,多谢各位大侠啊,非常感谢!
- 为什么这个程序求不出公式?
- 这个链表倒置的算法请大家分析下
- c语言函数库调用
- C语言unsigned int纠错
- C语言快排求解啊