当前位置:编程学习 > C/C++ >>

zju——Simple Task

原题:

Given a positive integer n and the odd integer o and the nonnegative integer p such that n = o2^p.

 

Example

 

For n = 24, o = 3 and p = 3.

 

Task

 

Write a program which for each data set:

reads a positive integer n,

 

computes the odd integer o and the nonnegative integer p such that n = o2^p,

 

writes the result.

 

Input

 

The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.

 

Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.

 

Output

 

The output should consists of exactly d lines, one line for each data set.

Line i, 1 <= i <= d, corresponds to the i-th input and should contain two integers o and p separated by a single space such that n = o2^p.

 

Sample Input

1

24

 

Sample Output

3 3

 

原码:

[cpp]
#include < stdio.h>  
 
   #include < math.h>  
 
   int main() 
 
   { 
 
   int N; 
 
   int cases; 
 
   int i,j; 
 
   int flag; 
 
   scanf("%d",&cases); 
 
   while(cases--) 
 
   { 
 
      scanf("%d",&N); 
 
      flag =0; 
 
      for(i=1;;i+=2) 
 
      { 
 
       for(j=0;;j++) 
 
       { 
 
        if( (i*pow(2,j))>N) 
 
         break; 
 
        if(i*pow(2,j)==N ) 
 
        { 
 
         printf("%d %d\n",i,j); 
 
         flag =1; 
 
         break; 
 
        } 
 
       } 
 
       if(flag ==1) 
 
        break; 
 
      } 
 
   } 
 
   return 0; 
 
   } 

补充:软件开发 , C++ ,
CopyRight © 2022 站长资源库 编程知识问答 zzzyk.com All Rights Reserved
部分文章来自网络,