当前位置:编程问答 > C#/ASP.NET >

程序集的编译时候怎么指定.netFramework的版本

问题:我在2010的VS里面做了一个类如JsHelper.cs,我用2010的DOS命令窗编译这个dll文件, 但是由于一个网站的版本是2.0我添加到这个网站的bin目录里面的就报错了!问题现在的环境是不能改变的~我就想能不能在编译dll的时候指定版本!求各位大神指导下
追问:我的cs文件不是在类库里面~而是就是一个app_Code里面的.cs类文件。是不是要在类库里面新建类呢?
答案:编译的时候设置项目的目标版本就可以了
http://msdn.microsoft.com/zh-cn/library/bb398202.aspx
http://msdn.microsoft.com/zh-cn/library/bb398791.aspx
其他:版本在AssemblyInfo.cs文件 路路通 C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\csc.exe

用对应版本目录下的csc.exe进行编译,如果没有这个目录,证明相应的.NET Framework没有安装 

上一个:.net游戏中,我用Label控件的背景颜色作为血量,我要保存游戏,要获取当前的血量,怎么获取呢?谢谢指导。
下一个:.net 2.0安装失败

CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,