当前位置:编程学习 > C/C++ >>

A+B for Input-Output Practice(1)

描述
 
 
Your task is to Calculate the sum of some integers.
 
输入
 
Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.
 
输出
 
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.
 
样例输入
 
4 1 2 3 4
5 1 2 3 4 5
0
样例输出
 
10
15
题目来源
 
HHUACM
 
题目上传者
 
06036
 
题目难度
 
1(0-9:0表示不确定,1表示最容易,依次逐难,9表示最难)
 
 
 
 
 
#include<iostream>  
using namespace std;  
int main()  
{  
    int n,a;  
    while(cin>>n&& n)  
    {  
        int m=0;  
        for(int i=0;i<n;i++)  
        {  
            cin>>a;  
            m+=a;  
        }  
        cout<<m<<endl;  
    }  
    return 0;  
}  

 

 
补充:软件开发 , C++ ,
CopyRight © 2022 站长资源库 编程知识问答 zzzyk.com All Rights Reserved
部分文章来自网络,