UVa 10341 - Solve It
原题:
Solve the equation:
p*e-x + q*sin(x) + r*cos(x) + s*tan(x) + t*x2 + u = 0
where 0 <= x <= 1.
Input
Input consists of multiple test cases and terminated by an EOF. Each test case consists of 6 integers in a single line: p, q, r, s, t and u(where 0 <= p,r <= 20 and -20 <= q,s,t <= 0). There will be maximum 2100 lines in the input file.
Output
For each set of input, there should be a line containing the value of x, correct upto 4 decimal places, or the string "No solution", whichever is applicable.
Sample Input
0 0 0 0 -2 1
1 0 0 0 -1 2
1 -1 1 -1 -1 1
Sample Output
0.7071
No solution
0.7554
分析与总结:
非线性方程求根问题, LRJ《算法入门经典》p150有类似的问题。 要求的跟是0~1之间, 而且这个方程是单调递减的,所以可以用二分来求根。
[cpp]
/*
* UVa: 10341 - Solve It
* Time: 0.024s
* Result: Accept
* Author: D_Double
*
*/
#include<iostream>
#include<cstdio>
#include<cmath>
#define EPS (10e-8)
using namespace std;
double p,q,r,s,t,u;
inline double fomula(double x){
return p*exp(-x)+q*sin(x)+r*cos(x)+s*tan(x)+t*x*x+u;
}
int main(){
while(scanf("%lf%lf%lf%lf%lf%lf",&p,&q,&r,&s,&t,&u)!=EOF){
double left=0, right=1, mid;
bool flag=false;
if(fomula(left)*fomula(right) > 0){
printf("No solution\n");
continue;
}
while(right-left > EPS){
mid = (left+right)/2;
if(fomula(mid)*fomula(left) > 0) left=mid;
else right=mid;
}
printf("%.4f\n", mid);
}
return 0;
}
作者:shuangde800
补充:软件开发 , C++ ,