POJ 3122 Pie
Pie
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7639 Accepted: 2817 Special Judge
Description
My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.
My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.
What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
Input
One line with a positive integer: the number of test cases. Then for each test case:
One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.
One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.
Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10−3.
Sample Input
3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2
Sample Output
25.1327
3.1416
50.2655
Source
Northwestern Europe 2006
愁啊,这精度问题真是让人不知所措啊,思路正确因为精度问题卡在那了,最初做题的时候double数据强转成int,
直接转,后来随着做题,因为在强转的时候没有加0.01错了很多次,所以就养成了,强转是+0.01的习惯,而今天做的这个题目是必须不能加,加了就错,直接强转就可以了。
[cpp]
#include <stdio.h>
#include <string.h>
#include <math.h>
#define PI 3.1415926535898
#define EQS 1e-7
double a[11000];
int n,m;
int main()
{
double binary_search(double l,double r);
int t,i;
double res,max;
scanf("%d",&t);
while(t--)
{
scanf("%d %d",&n,&m);
m++;
for(i=0,max=0;i<=n-1;i++)
{
scanf("%lf",&a[i]);
if(a[i]>max)
{
max=a[i];
}
}
res=binary_search(0,max*max*PI);
printf("%.4lf\n",res);
}
return 0;
}
int check(double mid)
{
int s=0,i;
for(i=0;i<=n-1;i++)
{
s+=(int)(a[i]*a[i]*PI/mid);
}
if(s>=m)
{
return 1;
}else
{
return 0;
}
}
double binary_search(double l,double r)
{
int t;
double mid;
while(!(fabs(r-l)<=EQS))
{
mid=(r+l)/2.0;
if(!check(mid))
{
r=mid;
}else
{
l=mid;
}
}
return l;
}
补充:软件开发 , C++ ,