当前位置:编程学习 > C/C++ >>

POJ3140:Contestants Division(DFS,树形DP)

Contestants Division
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 6947   Accepted: 1961
Description

In the new ACM-ICPC Regional Contest, a special monitoring and submitting system will be set up, and students will be able to compete at their own universities. However there’s one problem. Due to the high cost of the new judging system, the organizing committee can only afford to set the system up such that there will be only one way to transfer information from one university to another without passing the same university twice. The contestants will be divided into two connected regions, and the difference between the total numbers of students from two regions should be minimized. Can you help the juries to find the minimum difference?

Input

There are multiple test cases in the input file. Each test case starts with two integers N and M, (1 ≤ N ≤ 100000, 1 ≤ M ≤ 1000000), the number of universities and the number of direct communication line set up by the committee, respectively. Universities are numbered from 1 to N. The next line has N integers, the Kth integer is equal to the number of students in university numbered K. The number of students in any university does not exceed 100000000. Each of the following M lines has two integers s, t, and describes a communication line connecting university s and university t. All communication lines of this new system are bidirectional. www.zzzyk.com

N = 0, M = 0 indicates the end of input and should not be processed by your program.

Output

For every test case, output one integer, the minimum absolute difference of students between two regions in the format as indicated in the sample output.

Sample Input

7 6
1 1 1 1 1 1 1
1 2
2 7
3 7
4 6
6 2
5 7
0 0
Sample Output

Case 1: 1
Source

Shanghai 2006
MYCode:
#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
typedef long long LL;
using namespace std;
#define MAX 100010
//#define inf 100000000
struct node
{
    int v;
    int next;
}E[1000010];
bool vis[MAX];
LL sum[MAX];
int head[MAX];
LL v[MAX];
int num;
int n,m;
LL tot;
LL ans;
void init()
{
    memset(head,-1,sizeof(head));
    memset(vis,0,sizeof(vis));
    num=0;
}
void add(int s,int t)
{
    E[num].v=t;
    E[num].next=head[s];
    head[s]=num++;
}
void dfs(int cur)
{

    vis[cur]=1;
    int i;
    LL res;
    LL s=0;
    for(i=head[cur];i!=-1;i=E[i].next)
    {
        int v=E[i].v;
        if(vis[v])
        continue;
        dfs(v);
        s+=sum[v];
        res=abs((tot-sum[v])-sum[v]*1.0);
        //cout<<"res="<<res<<endl;
        if(res<ans)
        ans=res;
    }
    sum[cur]=s+v[cur];
    LL add=tot-sum[cur];
    res=abs((tot-add)-add*1.0);
    if(res<ans)
    {
        ans=res;
        //cout<<"res="<<res<<endl;
    }
}

int main()
{
    int ct=0;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(n==0&&m==0)
        break;
        init();
        int i;
        tot=0;
        for(i=1;i<=n;i++)
        {
            //scanf("%lld",&v[i]);
            cin>>v[i];
            tot+=v[i];
        }
        int s,t;
        for(i=1;i<=m;i++)
        {
            scanf("%d%d",&s,&t);
            add(s,t);
            add(t,s);
        }
        ans=tot;
        dfs(1);
        /*for(i=1;i<=n;i++)
        cout<<sum[i]<<" ";
        cout<<endl;*/
        //printf("%d\n",ans);
        cout<<"Case "<<++ct<<": "<<ans<<endl;
    }
}

//750MS

将原来的树划分后必然成为成为2棵树,其中一棵树是以原来树中的某个顶点为根的子树,所以可以在DFS过程枚举所有的顶点,找出最小值.

这道题应该还有更好的做法,动态规划的思路想不到.

750MS的效率,不是一个满意的答案.
 

补充:软件开发 , C++ ,
CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,