当前位置:编程学习 > C/C++ >>

hdu 4081 Qin Shi Huang's National Road System (最小生成树变形 两种解法 1.Prim 2.dfs)

Qin Shi Huang's National Road System
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2027    Accepted Submission(s): 741
 
 
Problem Description
During the Warring States Period of ancient China(476 BC to 221 BC), there were seven kingdoms in China ---- they were Qi, Chu, Yan, Han, Zhao, Wei and Qin. Ying Zheng was the king of the kingdom Qin. Through 9 years of wars, he finally conquered all six other kingdoms and became the first emperor of a unified China in 221 BC. That was Qin dynasty ---- the first imperial dynasty of China(not to be confused with the Qing Dynasty, the last dynasty of China). So Ying Zheng named himself "Qin Shi Huang" because "Shi Huang" means "the first emperor" in Chinese.
 
 
Qin Shi Huang undertook gigantic projects, including the first version of the Great Wall of China, the now famous city-sized mausoleum guarded by a life-sized Terracotta Army, and a massive national road system. There is a story about the road system:
There were n cities in China and Qin Shi Huang wanted them all be connected by n-1 roads, in order that he could go to every city from the capital city Xianyang.
Although Qin Shi Huang was a tyrant, he wanted the total length of all roads to be minimum,so that the road system may not cost too many people's life. A daoshi (some kind of monk) named Xu Fu told Qin Shi Huang that he could build a road by magic and that magic road would cost no money and no labor. But Xu Fu could only build ONE magic road for Qin Shi Huang. So Qin Shi Huang had to decide where to build the magic road. Qin Shi Huang wanted the total length of all none magic roads to be as small as possible, but Xu Fu wanted the magic road to benefit as many people as possible ---- So Qin Shi Huang decided that the value of A/B (the ratio of A to B) must be the maximum, which A is the total population of the two cites connected by the magic road, and B is the total length of none magic roads.
Would you help Qin Shi Huang?
A city can be considered as a point, and a road can be considered as a line segment connecting two points.
 
 
Input
The first line contains an integer t meaning that there are t test cases(t <= 10).
For each test case:
The first line is an integer n meaning that there are n cities(2 < n <= 1000).
Then n lines follow. Each line contains three integers X, Y and P ( 0 <= X, Y <= 1000, 0 < P < 100000). (X, Y) is the coordinate of a city and P is the population of that city.
It is guaranteed that each city has a distinct location.
 
 
Output
For each test case, print a line indicating the above mentioned maximum ratio A/B. The result should be rounded to 2 digits after decimal point.
 
 
Sample Input
2
4
1 1 20
1 2 30
200 2 80
200 1 100
3
1 1 20
1 2 30
2 2 40
 
 
Sample Output
65.00
70.00
 
 
Source
2011 Asia Beijing Regional Contest
 
 
思路1:
枚举a,保证每种情况b最小
先用Prim算最小生成树,算的时候统计maxcost[u][v](最小生成树上u到v的唯一路径上的最大边的值),然后二重循环枚举a(即枚举magic road),这样最小生成树会形成一个回路,删除maxcost[u][v]就够了(对每一种a保证了b最小)。
 
代码:
 
#include <cstdio>  
#include <cmath>  
#include <cstring>  
#include <vector>  
#include <algorithm>  
#define maxn 1005  
#define INF 0x3f3f3f3f  
using namespace std ;  
  
int n,m;  
bool vis[maxn];  
int pre[maxn];  
double sum,ans;  
double dist[maxn];  
double city[maxn][maxn],dd[maxn][maxn];  
vector<int>v;  
struct Node  
{  
    int x,y,p;  
}pp[maxn];  
  
void init()  
{  
    int i,j;  
    v.clear();  
    for(i=1;i<=n;i++)  
    {  
        dist[i]=INF;  
        for(j=1;j<=n;j++)  
        {  
            city[i][j]=INF;  
        }  
    }  
    memset(vis,0,sizeof(vis));  
    memset(dd,0,sizeof(dd));  
}  
double caldist(int k1,int k2)  
{  
    double xx,yy;  
    xx=pp[k1].x-pp[k2].x;  
    yy=pp[k1].y-pp[k2].y;  
    return sqrt(xx*xx+yy*yy);  
}  
void presolve()  
{  
    int i,j;  
    for(i=1;i<=n;i++)  
    {  
        for(j=i+1;j<=n;j++)  
        {  
            city[i][j]=city[j][i]=caldist(i,j);  
        }  
    }  
}  
void prim()  
{  
    int i,j,k,sz,now=1;  
    double mi;  
    sum=0;  
    vis[1]=1;  
    dist[1]=0;  
    v.push_back(1);  
    for(i=1;i<n;i++)  
    {  
        for(j=1;j<=n;j++)  
        {  
            if(!vis[j]&&city[now][j]<dist[j])  
                pre[j]=now,dist[j]=city[now][j];  
        }  
        mi=INF;  
        for(j=1;j<=n;j++)  
        {  
            if(!vis[j]&&dist[j]<mi)  
            {  
                mi=dist[j];  
                k=j;  
            }  
        }  
        sum+=dist[k];  
        now=k;  
        vis[k]=1;  
        sz=v.size();  
        for(j=0;j<sz;j++)  
        {  
            dd[v[j]][k]=dd[k][v[j]]=max(dd[v[j]][pre[k]],dist[k]);  
        }  
        v.push_back(k);  
    }  
}  
void solve()  
{  
    int i,j;  
    double a,b;  
    ans=0;  
    for(i=1;i<=n;i++)  
    {  
        for(j=i+1;j<=n;j++)  
        {  
            a=pp[i].p+pp[j].p;  
            b=sum-dd[i][j];  
            if(ans<a/b) ans=a/b;  
        }  
    }  
}  
int main()  
{  
    int i,j,t;  
    scanf("%d",&t);  
    while(t--)  
    {  
        scanf("%d",&n);  
        init();  
        for(i=1;i<=n;i++)  
        {  
            scanf("%d%d%d",&pp[i].x,&pp[i].y,&pp[i].p);  
        }  
        presolve();  
        prim();  
        solve();  
        printf("%.2f\n",ans);  
    }  
    return 0;  
}  

 

 
 
思路2:
枚举b,每种情况保证a最大。
先用Prim求出最小生成树,求的同时构图,然后依次删除最小生成树的每一条边,删除一条边后会形成两颗树,而magic road肯定1.要把两棵树连起来。2.保证a最大。所以只需要分别找到两棵树中的最大的人口数就够了。这个可以在图上用dfs实现。
 
感想:
这个思路我比赛时想到了,没想到构图,感觉找到两棵树中的最大的人口数不好处理,就放弃了这个思路,╮(╯▽╰)╭,说多了都是泪,其实还是题做少了,算法学死了。。。
 
代码:
 
#include <cstdio>  
#include <cmath>  
#include <cstring>  
#include <algorithm>  
#define maxn 1005  
#define INF 0x3f3f3f3f  
using namespace std ;  
  
int n,m,cnt,nu,nv,maxp;  
bool vis[maxn];  
int pre[maxn];  
double sum,ans;  
double dist[maxn];  
double city[maxn][maxn],dd[maxn][maxn];  
struct Node  
{  
    int x,y,p;  
}pp[maxn];  
int pt[maxn];  
struct node  
{  
    int v,next;  
}edge[maxn<<1];  
struct Tnode  
{  
    int u,v;  
    double cost;  
}mst[maxn];  
  
void init()  
{  
    int i,j;  
    for(i=1;i<=n;i++)  
    {  
        dist[i]=INF;  
        for(j=1;j<=n;j++)  
        {  
            city[i][j]=INF;  
        }  
    }  
    cnt=0;  
    memset(pt,0,sizeof(pt));  
    memset(vis,0,sizeof(vis));  
}  
double caldist(int k1,int k2)  
{  
    double xx,yy;  
    xx=pp[k1].x-pp[k2].x;  
    yy=pp[k1].y-pp[k2].y;  
    return sqrt(xx*xx+yy*yy);  
}  
void presolve()  
{  
    int i,j;  
    for(
补充:软件开发 , C++ ,
CopyRight © 2022 站长资源库 编程知识问答 zzzyk.com All Rights Reserved
部分文章来自网络,