HDU 2674 N! Again
Problem Description
WhereIsHeroFrom: Zty, what are you doing ?
Zty: I want to calculate N!......
WhereIsHeroFrom: So easy! How big N is ?
Zty: 1 <=N <=1000000000000000000000000000000000000000000000…
WhereIsHeroFrom: Oh! You must be crazy! Are you Fa Shao?
Zty: No. I haven's finished my saying. I just said I want to calculate N! mod 2009
Hint : 0! = 1, N! = N*(N-1)!
Input
Each line will contain one integer N(0 <= N<=10^9). Process to end of file.
Output
For each case, output N! mod 2009
Sample Input
4
5
Sample Output
24
120
求N! MOD 2009的结果
我们这可这样想,如果在N!里找几个数乘的积等于2009就好了
结果我就弄了个循坏暴力了下,得知 2009=7*7*41=41*49;
也就是说当N>=49时N! MOD 2009=0;
当N<49时我们就可以暴力了,水了吧。
LANGUAGE:C
CODE:
#include<stdio.h>
int main()
{
int n;
__int64 mul;
while(scanf("%d",&n)!=EOF)
{
mul=1;
if(n>=49)
{
printf("0\n");
continue;
}
while(n>1)
{
mul*=n;
mul%=2009;
n--;
}
printf("%I64d\n",mul);
}
return 0;
}
作者:ultimater
补充:软件开发 , C++ ,