POJ 3278 Catch That Cow
Catch That CowTime Limit: 2000MS Memory Limit: 65536K
Total Submissions: 30437 Accepted: 9390
Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
这个看完了我顿时沸腾了起来,写的太好了,bfs与队列的完美结合,谢谢作者。
[html]
#include <iostream>
#include <queue>
#define SIZE 100001
using namespace std;
queue<int> x;
bool visited[SIZE];
int step[SIZE];
int bfs(int n, int k)
{
int head, next;
//起始节点入队
x.push(n);
//标记n已访问
visited[n] = true;
//起始步数为0
step[n] = 0;
//队列非空时
while (!x.empty())
{
//取出队头
head = x.front();
//弹出队头
x.pop();
//3个方向搜索
for (int i = 0; i < 3; i++)
{
if (i == 0) next = head - 1;
else if (i == 1) next = head + 1;
else next = head * 2;
//越界就不考虑了
if (next > SIZE || next < 0) continue;
//判重
if (!visited[next])
{
//节点入队
x.push(next);
//步数+1
step[next] = step[head] + 1;
//标记节点已访问
visited[next] = true;
}
//找到退出
if (next == k) return step[next];
}
}
}
int main()
{
int n, k;
cin >> n >> k;
if (n >= k)
{
cout << n - k << endl;
}
else
{
cout << bfs(n, k) << endl;
}
return 0;
}
作者:princeyuaner
补充:软件开发 , C++ ,