当前位置:编程学习 > C/C++ >>

hdu3714 Error Curves---三分复习

Error Curves
Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1151    Accepted Submission(s): 440


Problem Description
Josephina is a clever girl and addicted to Machine Learning recently. She
pays much attention to a method called Linear Discriminant Analysis, which
has many interesting properties.
In order to test the algorithm's efficiency, she collects many datasets.
What's more, each data is divided into two parts: training data and test
data. She gets the parameters of the model on training data and test the
model on test data. To her surprise, she finds each dataset's test error curve is just a parabolic curve. A parabolic curve corresponds to a quadratic function. In mathematics, a quadratic function is a polynomial function of the form f(x) = ax2 + bx + c. The quadratic will degrade to linear function if a = 0.

 


It's very easy to calculate the minimal error if there is only one test error curve. However, there are several datasets, which means Josephina will obtain many parabolic curves. Josephina wants to get the tuned parameters that make the best performance on all datasets. So she should take all error curves into account, i.e., she has to deal with many quadric functions and make a new error definition to represent the total error. Now, she focuses on the following new function's minimum which related to multiple quadric functions. The new function F(x) is defined as follows: F(x) = max(Si(x)), i = 1...n. The domain of x is [0, 1000]. Si(x) is a quadric function. Josephina wonders the minimum of F(x). Unfortunately, it's too hard for her to solve this problem. As a super programmer, can you help her?

Input
The input contains multiple test cases. The first line is the number of cases T (T < 100). Each case begins with a number n (n ≤ 10000). Following n lines, each line contains three integers a (0 ≤ a ≤ 100), b (|b| ≤ 5000), c (|c| ≤ 5000), which mean the corresponding coefficients of a quadratic function.

Output
For each test case, output the answer in a line. Round to 4 digits after the decimal point.

Sample Input
2
1
2 0 0
2
2 0 0
2 -4 2

Sample Output
0.0000
0.5000

Author
LIN, Yue

Source
2010 Asia Chengdu Regional Contest

Recommend
zhouzeyong
读题是个问题,这题给n个二项式,定义F(x)为x在(0,1000)这个范围内的所有二项式的最大值,求F(x)的最小值
[cpp] 
#include<iostream> 
#include<cstdlib> 
#include<stdio.h> 
#include<algorithm> 
#include<math.h> 
#define eps 1e-15 
const int N=10010; 
using namespace std; 
double a[N],b[N],c[N]; 
int n; 
double cal(double xx) 

    double ans=a[0]*xx*xx+b[0]*xx+c[0]; 
    for(int i=1;i<n;i++) 
    ans=max(ans,a[i]*xx*xx+b[i]*xx+c[i]); 
    return ans; 

double solve() 

    double left,right; 
    double mid,midmid; 
    double mid_area,midmid_area; 
    left=0;right=1000; 
    while(left+eps<right) 
    { 
        mid=(left+right)/2; 
        midmid=(mid+right)/2; 
        mid_area=cal(mid); 
        midmid_area=cal(midmid); 
        if(mid_area>midmid_area) left=mid; 
        else right=midmid; 
    } 
    return cal(right); 

int main() 

    int t; 
    scanf("%d",&t); 
    while(t--) 
    { 
        scanf("%d",&n); 
        for(int i=0;i<n;i++) 
        scanf("%lf%lf%lf",&a[i],&b[i],&c[i]); 
        double f=solve(); 
        printf("%.4lf\n",f); 
    } 

  
      

补充:软件开发 , C++ ,
CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,