当前位置:编程学习 > C/C++ >>

hdu Leftmost Digit

思路:刚开始做,发现很纠结!!

后来,看到了一个人的分析,是这样转换的

m=n^n;两边同取对数,得到,log10(m)=n*log10(n);再得到,m=10^(n*log10(n));

然后,对于10的整数次幂,第一位是1,所以,第一位数取决于n*log10(n)的小数部分

总之,log很强大啊,在求一个数的位数上,在将大整数化成范围内的整数上,在指数问题上
    

Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
Input
The input contains several test cases. The first line of the input is a single integer T which is the

number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Output
For each test case, you should output the leftmost digit of N^N.
Sample Input
2
3
4
Sample Output
2
2
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2.
In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
 
代码:
[cpp] 
<span style="font-family:FangSong_GB2312;font-size:18px;">#include<iostream> 
#include<cmath> 
using namespace std; 
int main() 

    __int64 i,t,a,sum; 
    double s,x,n; 
    cin>>t; 
    while(t--) 
    { 
      cin>>n; 
      s=n*log10(n); 
      a=(__int64)s; 
      x=s-a; 
      sum=(__int64)pow(10.0,x); 
      cout<<sum<<endl; 
    } 
    return 0; 
}</span> 

补充:软件开发 , C++ ,
CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,