当前位置:编程学习 > C/C++ >>

POJ 3009 Curling 2.0

Curling 2.0
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7634 Accepted: 3179
Description
 
On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.
 
Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.
 
Fig. 1: Example of board (S: start, G: goal)
 
The movement of the stone obeys the following rules:
 
At the beginning, the stone stands still at the start square.
The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
Once thrown, the stone keeps moving to the same direction until one of the following occurs:
The stone hits a block (Fig. 2(b), (c)).
The stone stops at the square next to the block it hit.
The block disappears.
The stone gets out of the board.
The game ends in failure.
The stone reaches the goal square.
The stone stops there and the game ends in success.
You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.
Fig. 2: Stone movements
 
Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.
 
With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).
 
Fig. 3: The solution for Fig. D-1 and the final board configuration
 
Input
 
The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.
 
Each dataset is formatted as follows.
 
the width(=w) and the height(=h) of the board 
First row of the board 
... 
h-th row of the board
 
The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.
 
Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.
 
0 vacant square
1 block
2 start position
3 goal position
The dataset for Fig. D-1 is as follows:
 
6 6 
1 0 0 2 1 0 
1 1 0 0 0 0 
0 0 0 0 0 3 
0 0 0 0 0 0 
1 0 0 0 0 1 
0 1 1 1 1 1
 
Output
 
For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.
 
Sample Input
 
2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0
Sample Output
 
1
4
-1
4
10
-1
Source
 
Japan 2006 Domestic
这题的思路很是清晰,因为次数不能大于10,所以递归不会太深,用dfs就可以了,但是在调程序的时候花费了很长时间,幸好是一次就过了。一定要注意变量的变化
[cpp]  
#include <stdio.h>  
#include <string.h>  
#include <math.h>  
int a[40][40];  
int stax,stay,endx,endy,step,flag,n,m,resStep;  
int vex[]={0,0,-1,1};  
int vey[]={-1,1,0,0};  
int INF=0x7fffffff;  
int main()  
{  
    void dfs(int x,int y);  
    int i,j,s,t;  
    while(scanf("%d %d",&m,&n)!=EOF)  
    {  
        if(!m&&!n)  
        {  
            break;  
        }  
        for(i=0;i<=n-1;i++)  
        {  
            for(j=0;j<=m-1;j++)  
            {  
                scanf("%d",&a[i][j]);  
                if(a[i][j]==2)  
                {  
                    stax=i; stay=j;  
                }else if(a[i][j]==3)  
                {  
                    endx=i; endy=j;  
                }  
            }  
        }  
        step=0;flag=0;resStep=INF;  
        dfs(stax,stay);  
        if(flag==0)  
        {  
            printf("-1\n");  
        }else  
        {  
            printf("%d\n",resStep);  
        }  
    }  
    return 0;  
}  
void dfs(int x,int y)  
{  
    int i,j,xend,yend,k,orx,ory;  
    orx=x; ory=y;  
    for(i=0;i<=3;i++)  
    {  
        step++;  
      &nb
补充:软件开发 , C++ ,
CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,