HDU1228:A + B
Problem Description读入两个小于100的正整数A和B,计算A+B.
需要注意的是:A和B的每一位数字由对应的英文单词给出.
Input
测试输入包含若干测试用例,每个测试用例占一行,格式为"A + B =",相邻两字符串有一个空格间隔.当A和B同时为0时输入结束,相应的结果不要输出.
Output
对每个测试用例输出1行,即A+B的值.
Sample Input
one + two =
three four + five six =
zero seven + eight nine =
zero + zero =
Sample Output
3
90
96
[cpp]
#include <iostream>
#include <cstdio>
#include <string.h>
using namespace std;
char num[10][10] = {"zero","one","two","three","four","five","six","seven","eight","nine"};
int search(char ch[])
{
int i;
for(i = 0;i<10;i++)
{
if(!strcmp(ch,num[i]))
break;
}
return i;
}
int main()
{
char count[10];
int a,b;
while(1)
{
a = 0;
while(scanf("%s",count) && strcmp(count,"+"))
{
a = a*10+search(count);
}
b = 0;
while(scanf("%s",count) && strcmp(count,"="))
{
b = b*10+search(count);
}
if(a == 0 && b == 0)
return 0;
else
cout << a+b << endl;
}
return 0;
}
补充:软件开发 , C++ ,