当前位置:编程学习 > C/C++ >>

PAT-1050 String Substraction

题目:http://pat.zju.edu.cn/contests/pat-101-103-1-2013-03-10/A
题目描述:
Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2 for any given strings. However, it might not be that simple to do it fast.
Input Specification:
Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.
Output Specification:
For each test case, print S1 - S2 in one line.
Sample Input:
They are students.
aeiou
Sample Output:
Thy r stdnts.
 
分析:怎么样快速的查询时关键,使用暴搜一定会超时的。
以下代码来自于:http://blog.csdn.net/sunbaigui/article/details/8656788
 
#include<iostream>    
#include <set>    
#include <vector>    
#include <map>    
#include <queue>    
#include <stack>    
#include <string>    
#include <string.h>    
#include <algorithm>    
using namespace std;    
    
#define  MAX 1000    
int main()    
{    
    string a, b;  
    int i;  
    getline(cin, a);    
    getline(cin, b);    
    vector<bool> existed(MAX, false);    
    for (i = 0; i < b.size(); ++i)    
        existed[b[i]] = true;    
    for ( i = 0; i < a.size(); ++i)    
        if (!existed[a[i]]) printf("%c",a[i]);    
    cout<<endl;  
    return 0;    
}    

 

 
补充:软件开发 , C++ ,
CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,