当前位置:编程学习 > 网站相关 >>

贪心算法——Hdu 1050 Moving Tables

Moving Tables
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12304    Accepted Submission(s): 4226


Problem Description
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.

 


The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.

 


For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.
 

Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.
 

Output
The output should contain the minimum time in minutes to complete the moving, one per line.
 

Sample Input
3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50
 

Sample Output
10
20
30

需要注意的是房间与走廊的位置关系,就如图中所给的图片所示

 

相对门的两个房间占用同一处走廊,所以例如有1——3和4——6移动方式时,它们是共享了同一段走廊的,即3号房间门前的走廊。

分析过程有如下图所示

 

代码一

[cpp]
#include <cstdio> 
#include <algorithm> 
 
using namespace std; 
 
#define SIZE 205 
 
struct Data_Type 

    int from, to; 
    bool flag; 
}moving[SIZE]; 
 
bool Cmp(const Data_Type a, const Data_Type b) 

    return a.from < b.from; 

 
int main(void) 

    int i, testNum, n; 
 
    scanf("%d", &testNum); 
    while (testNum-- != 0) 
    { 
        scanf("%d", &n); 
        for (i = 0; i < n; i++) 
        { 
            scanf("%d%d", &moving[i].from, &moving[i].to); 
            if (moving[i].from > moving[i].to) 
            { 
                int temp = moving[i].from; 
                moving[i].from = moving[i].to; 
                moving[i].to = temp; 
            } 
            if (moving[i].from % 2 == 0) 
            { 
                moving[i].from--; 
            } 
            if (moving[i].to % 2 == 1) 
            { 
                moving[i].to++; 
            } 
            moving[i].flag = false; 
        } 
        sort(moving, moving+n, Cmp); 
        bool completion = false; 
        int count = -1, priorTo; 
        while (!completion) 
        { 
            completion = true; 
            count++; 
            priorTo = 0; 
            for (i = 0; i < n; i++) 
            { 
                if (!moving[i].flag && moving[i].from > priorTo) 
                { 
                    moving[i].flag = true; 
                    priorTo = moving[i].to; 
                    completion = false; 
                } 
            } 
        } 
        printf("%d\n", count*10); 
    } 
    return 0; 

代码二

[cpp] 
#include <stdio.h> 
#include <string.h> 
 
#define SIZE 405 
 
int main(void) 

    int count[SIZE]; 
    int i, j, testNum, n, max, from, to; 
 
    scanf("%d", &testNum)

补充:综合编程 , 其他综合 ,
CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,