当前位置:编程学习 > C/C++ >>

UVa 10250 - The Other Two Trees

Problem E

The Other Two Trees

Input: standard input

Output: standard output

Time Limit: 2 seconds

 

You have a quadrilateral shaped land whose opposite fences are of equal length. You have four neighbors whose lands are exactly adjacent to your four fences, that means you have a common fence with all of them. For example if you have a fence of length d in one side, this fence of lengthd is also the fence of the adjacent neighbor on that side. The adjacent neighbors have no fence in common among themselves and their lands also don’t intersect. The main difference between their land and your land is that their lands are all square shaped. All your neighbors have a tree at the center of their lands. Given the Cartesian coordinates of trees of two opposite neighbors, you will have to find the Cartesian coordinates of the other two trees.

 

Input
The input file contains several lines of input. Each line contains four floating point or integer numbers x1, y1, x2, y2, where (x1, y1), (x2, y2) are the coordinates of the trees of two opposite neighbors. Input is terminated by end of file.

 

Output
For each line of input produce one line of output which contains the line “Impossible.” without the quotes, if you cannot determine the coordinates of the other two trees. Otherwise, print four floating point numbers separated by a single space with ten digits after the decimal point ax1, ay1, ax2, ay2, where (ax1, ay1)  and (ax2, ay2) are the coordinates of the other two trees. The output will be checked with special judge program, so don’t worry about the ordering of the points or small precision errors. The sample output will make it clear.

 

Sample Input
10 0 -10 0

10 0 -10 0

10 0 -10 0

 

Sample Output
0.0000000000 10.0000000000 0.0000000000 -10.0000000000

0.0000000000 10.0000000000 -0.0000000000 -10.0000000000

0.0000000000 -10.0000000000 0.0000000000 10.0000000000


--------------------------------------------------------------------------------

(World Final Warm-up Contest, Problem Setter: Shahriar Manzoor)


============

2 思路
这个题其实是已知正方形两个对角顶点坐标,求其它两个坐标。觉得不难,但是刚开始 一直想不出怎么解决,画了画图,又看了看别人的思路才明白,看来小学数学白学了。

一图胜千言:\
 

 


注意图中的四个三角形是全等的,对照图以及代码中的计算过程很容易明白。

3 代码、
 

#include <stdio.h>
#include <math.h>

#define EPS 1e-8

int main() {
  double x1,y1,x2,y2;
  double ax1, ay1, ax2, ay2;
  double a, b;

  while (scanf ("%lf%lf%lf%lf", &x1, &y1, &x2, &y2) != EOF) {
    if (fabs(x1-x2)<EPS && fabs(y1-y2)<EPS) {
      printf ("Impossible.\n");
      continue;
    }

    a = (y1-y2+x2-x1)/2;
    b = (y1-y2-x2+x1)/2;

    ax1 = x2 - a;
    ay1 = y2 + b;
    ax2 = x2 + b;
    ay2 = y2 + a;

    printf ("%.10lf %.10lf %.10lf %.10lf\n", ax1, ay1, ax2, ay2);

  }

  return 0;
}

 

补充:软件开发 , C++ ,
CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,