当前位置:编程学习 > C/C++ >>

CD UVA 624

You have a long drive by car ahead. You have a tape recorder, but unfortunately your best music is on CDs. You need to have it on tapes so the problem to solve is: you have a tape N minutes long. How to choose tracks from CD to get most out of tape space and have as short unused space as possible.

 

Assumptions:

number of tracks on the CD. does not exceed 20
no track is longer than N minutes
tracks do not repeat
length of each track is expressed as an integer number
N is also integer
Program should find the set of tracks which fills the tape best and print it in the same sequence as the tracks are stored on the CD


Input
Any number of lines. Each one contains value N, (after space) number of tracks and durations of the tracks. For example from first line in sample data: N=5, number of tracks=3, first track lasts for 1 minute, second one 3 minutes, next one 4 minutes

Output
Set of tracks (and durations) which are the correct solutions and string ``sum:" and sum of duration times.

Sample Input

5 3 1 3 4
10 4 9 8 4 2
20 4 10 5 7 4
90 8 10 23 1 2 3 4 5 7
45 8 4 10 44 43 12 9 8 2

Sample Output
1 4 sum:5
8 2 sum:10
10 5 4 sum:19
10 23 1 2 3 4 5 7 sum:55
4 10 12 9 8 2 sum:45
两种写法都对,这题要用个深搜,把路径输出!可以转化成01背包用题 ,不错的DP入门题 !


/*
#include<stdio.h>
#include<iostream>
using namespace std;
int c[35],w[35],f[430000][30],visit[35];
void print(int i,int j)
{

 if(!j)return ;
 if(f[i][j] == f[i][j-1]) print(i, j-1);
    else
    {
        print(i-c[j-1],j-1 );
        printf("%d ", c[j-1]);
    }

}
int main()
{
 int i,j,n,v,m;
 while(scanf("%d%d",&m,&n)!=EOF)
 {
  for(i=0;i<=m;i++)
  for( j=0;j<=n;j++)
   f[i][j]=0;
  for(i=0;i<n;i++)
  {
   scanf("%d",c+i);
   w[i]=c[i];
  } 
  for (i=1;i<=n;i++)
  {
   for (v=1; v <= m; v++)
   {
    if(v<c[i-1])
     f[v][i]=f[v][i-1];
    if(v>=c[i-1])
    f[v][i] = (f[v][i-1] > f[v - c[i-1]][i-1] + w[i-1]?f[v][i-1] : f[v - c[i-1]][i-1] + w[i-1]);
   }
  
  }
 
  v=m;
  
  print(m,n);
   printf("sum:%d\n",f[m][n]);
 }
 return 0;
}
*/
#include<stdio.h>
#include<iostream>
using namespace std;
int c[35],w[35],f[430000][30],visit[35];
void print(int i,int j)
{

 if(!j)return ;
 if(f[i][j] == f[i][j-1]) print(i, j-1);
    else
    {
        print(i-c[j-1],j-1 );
        printf("%d ", c[j-1]);
    }

}
int main()
{
 int i,j,n,v,m;
 while(scanf("%d%d",&m,&n)!=EOF)
 {
  for(i=0;i<=m;i++)
  for( j=0;j<=n;j++)
   f[i][j]=0;
  for(i=0;i<n;i++)
  {
   scanf("%d",c+i);
   w[i]=c[i];
  } 
  for (i=1;i<=n;i++)
  {
   for (v=m; v>=0; v--)
   {
    if(v<c[i-1])
     f[v][i]=f[v][i-1];
    if(v>=c[i-1])
    f[v][i] = (f[v][i-1] > f[v - c[i-1]][i-1] + w[i-1]?f[v][i-1] : f[v - c[i-1]][i-1] + w[i-1]);
   }
  
  }
 
  v=m;
   for(i=0;i<30;i++)
    visit[i]=0;
   
   print(v,n);
   printf("sum:%d\n",f[m][n]);
 }
 return 0;
}

 

补充:软件开发 , C++ ,
CopyRight © 2022 站长资源库 编程知识问答 zzzyk.com All Rights Reserved
部分文章来自网络,