poj1050 To the Max 最大子矩阵
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:
9 2
-4 1
-1 8
and has a sum of 15.
Input
The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
Output
Output the sum of the maximal sub-rectangle.
Sample Input
4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2Sample Output
15
最大子矩阵,首先一行数列很简单求最大的子和,我们要把矩阵转化成一行数列,就是从上向下在输入的时候取和,map[i][j]表示在J列从上向下的数和,这样就把一列转化成了一个点,再用双重,循环,任意i行j列开始的一排数的最大和,就是最终的最大和
#include <iostream> #include <stdio.h> using namespace std; int map[105][105]; int main() { int n,i,j,k,sum,x,max; while(scanf("%d",&n)!=EOF) { for(i=0;i<n;i++) for(j=0;j<n;j++) { scanf("%d",&x); map[i][j]=map[i-1][j]+x; } max=-0x4f4f4f4f; for(i=0;i<n;i++) for(j=i;j<n;j++) { sum=0; for(k=0;k<n;k++) { sum+=map[j][k]-map[i][k]; if(sum<0) //小于0就相当于不用取了,直接去掉 #include <iostream> #include <stdio.h> using namespace std; int map[105][105]; int main() { int n,i,j,k,sum,x,max; while(scanf("%d",&n)!=EOF) { for(i=0;i<n;i++) for(j=0;j<n;j++) { scanf("%d",&x); map[i][j]=map[i-1][j]+x; } max=-0x4f4f4f4f; for(i=0;i<n;i++) for(j=i;j<n;j++) { sum=0; for(k=0;k<n;k++) { sum+=map[j][k]-map[i][k]; if(sum<0) //小于0就相当于不用取了,直接去掉
sum=0;
if(sum>max)
max=sum;
}
}
printf("%d\n",max);
}
return 0;
}
sum=0;
if(sum>max)
max=sum;
}
}
printf("%d\n",max);
}
return 0;
}
补充:软件开发 , C++ ,