当前位置:编程学习 > C/C++ >>

Wolf and Rabbit

 
A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.
 
Input
The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).
 
Output
 
            For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.
 
Sample Input
2
1 2
2 2
 
Sample Output
NO
YES
 
 
[cpp] 
#include <iostream>  
  
using namespace std;  
  
int 易做图(int x,int y)  
{  
    int c;  
    if(x<c)  
    {  
        c=x;  
        x=y;  
        y=c;  
    }  
    if(y==0)  
    return x;  
    else return 易做图(y,x%y);    
}  
  
int main()  
{  
    int n;  
    cin>>n;  
    while(n--)  
    {  
        int a,b;  
        cin>>a>>b;  
        if(易做图(a,b)==1) cout<<"NO"<<endl;  
        else cout<<"YES"<<endl;  
    }  
    return 0;  
}   
 
 
 
补充:软件开发 , C++ ,
CopyRight © 2022 站长资源库 编程知识问答 zzzyk.com All Rights Reserved
部分文章来自网络,