当前位置:编程学习 > C/C++ >>

POJ 3273 Monthly Expense

Monthly Expense
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 9627 Accepted: 3943
Description
Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.
FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.
FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.
Input
Line 1: Two space-separated integers: N and M 
Lines 2..N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day
Output
Line 1: The smallest possible monthly limit Farmer John can afford to live with.
Sample Input
7 5
100
400
300
100
500
101
400
Sample Output
500
Hint
If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.
Source
USACO 2007 March Silver
看着别人写的做的,突然感觉二分还能这样用。
[cpp]  
#include <stdio.h>  
#include <string.h>  
#include <math.h>  
int a[100010],l,r,n,m;  
int main()  
{  
    int binary_search();  
    int i,j,s,t;  
    while(scanf("%d %d",&n,&m)!=EOF)  
    {  
        for(i=0,r=0,l=0;i<=n-1;i++)  
        {  
            scanf("%d",&a[i]);  
            if(a[i]>l)  
            {  
                l=a[i];  
            }  
            r+=a[i];  
        }  
        t=binary_search();  
        printf("%d\n",t);  
    }  
    return 0;  
}  
int check(int mon)  
{  
    int i=1,j,s;  
    for(j=0,s=0;j<=n-1;j++)  
    {  
        if((s+a[j])<=mon)  
        {  
            s+=a[j];  
        }else  
        {  
            s=a[j];  
            i++;  
        }  
    }  
    if(i>m)  
    {  
        return 0;  
    }else  
    {  
        return 1;  
    }  
}  
int binary_search()  
{  
    int mid;  
    while(l<r)  
    {  
        mid=(l+r)/2;  
        if(!check(mid))  
        {  
            l=mid+1;  
        }else  
        {  
            r=mid-1;  
        }  
    }  
    return l;  
}  
 
补充:软件开发 , C++ ,
CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,