POJ 1035 Spell checker
Spell checkerTime Limit: 2000MS Memory Limit: 65536K
Total Submissions: 15145 Accepted: 5504
Description
You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms.
If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations:
?deleting of one letter from the word;
?replacing of one letter in the word with an arbitrary letter;
?inserting of one arbitrary letter into the word.
Your task is to write the program that will find all possible replacements from the dictionary for every given word.
Input
The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000 words in the dictionary.
The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked.
All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most.
Output
Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.
Sample Input
i
is
has
have
be
my
more
contest
me
too
if
award
#
me
aware
m
contest
hav
oo
or
i
fi
mre
#
Sample Output
me is correct
aware: award
m: i my me
contest is correct
hav: has have
oo: too
or:
i is correct
fi: i
mre: more me
Source
Northeastern Europe 1998
首先 理清思路,用最普通的方法做就可以;
然后 睡觉
[cpp]
#include <iostream>
#include <string>
using namespace std;
string s1[20000];
string s2;
int main()
{
int i,j,n,m,s,t,x,k;
int l1,l2;
i=0;
while(1)
{
getline(cin,s2);
if(s2=="#")
{
break;
}
s1[i]=s2; i++;
}
n=i;
while(1)
{
getline(cin,s2);
if(s2=="#")
{
break;
}
for(i=0;i<=n-1;i++)
{
if(s1[i]==s2)
{
break;
}
}
if(i!=n)
{
cout<<s2<<" is correct"<<endl;
}else
{
cout<<s2<<":";
l2=s2.size();
for(i=0;i<=n-1;i++)
{
l1=s1[i].size();
k=0;
if(l1==l2)
{
for(j=0;j<=l1-1;j++)
{
if(s1[i][j]!=s2[j]&&k==0)
{
k=1;
}else if(s1[i][j]!=s2[j])
{
break;
}
}
if(j==l1)
{
cout<<" "<<s1[i];
}
}else if(l1-l2==1)
{
for(j=0,x=0;j<=l1-1;j++)
{
if(s1[i][j]!=s2[x]&&k==0)
{
&
补充:软件开发 , C++ ,
上一个:杭电OJ——1172 猜数字(水题)
下一个:朴素字符串匹配——算法导论
- 更多C/C++疑问解答:
- 关于c++的cout输出的问题。
- 在学校里学过C和C++,不过学的很一般,现在自学C#,会不会很难?
- 全国计算机二级C语言笔试题
- 已知某树有2个2度结点,3个3度结点,4个4度结点,问有几个叶子结点?
- c++数据结构内部排序问题,整数排序
- 2012九月计算机二级C语言全国题库,,急求急求
- 如果assert只有一个字符串作为参数,是什么意思呢?
- C语言中,哪些运算符具有左结合性,哪些具有右结合性,帮忙总结下,谢谢了!
- 为什么用结构体编写的程序输入是,0输不出来啊~~~
- 将IEEE—754的十六进制转化为十进制浮点类型,用C或C++都行,多谢各位大侠啊,非常感谢!
- 为什么这个程序求不出公式?
- 这个链表倒置的算法请大家分析下
- c语言函数库调用
- C语言unsigned int纠错
- C语言快排求解啊