当前位置:编程学习 > C/C++ >>

hdu4282 A very hard mathematic problem-----天津网络赛

A very hard mathematic problem
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 913    Accepted Submission(s): 268
 
 
Problem Description
  Haoren is very good at solving mathematic problems. Today he is working a problem like this:
  Find three positive integers X, Y and Z (X < Y, Z > 1) that holds
  X^Z + Y^Z + XYZ = K
  where K is another given integer.
  Here the operator “^”means power, e.g., 2^3 = 2 * 2 * 2.
  Finding a solution is quite easy to Haoren. Now he wants to challenge more: What’s the total number of different solutions?
  Surprisingly, he is unable to solve this one. It seems that it’s really a very hard mathematic problem.
  Now, it’s your turn.
 
Input
  There are multiple test cases.
  For each case, there is only one integer K (0 < K < 2^31) in a line.
  K = 0 implies the end of input.
  
 
Output
  Output the total number of solutions in a line for each test case.
 
Sample Input
9
53
6
0
 
Sample Output
1
1
0
  
Hint
 
9 = 1^2 + 2^2 + 1 * 2 * 2
53 = 2^3 + 3^3 + 2 * 3 * 3
 
 
Source
2012 ACM/ICPC Asia Regional Tianjin Online
 
Recommend
liuyiding
[cpp]
#include<iostream> 
#include<cstdlib> 
#include<stdio.h> 
#include<math.h> 
using namespace std; 
#define ll __int64 
ll power(ll x,int y) 

    ll temp=x; 
    for(int i=2;i<=y;i++) 
    temp*=x; 
    return temp; 

int main() 

    ll n; 
    while(scanf("%I64d",&n)&&n) 
    { 
        int ans=0; 
        int temp=sqrt(n); 
        if(temp*temp==n) ans+=(temp-1)/2; 
        for(int i=3;i<31;i++)//z 
        { 
          
          for(ll j=1;;j++) 
          { 
              ll y=power(j,i); 
              if(y>=n/2) break; 
              for(ll k=j+1;;k++)//先枚举小的 
              { 
                  ll x=power(k,i); 
                  ll uu=x+y+i*j*k; 
                  if(uu>n) break; 
                  else if(uu==n){ans++;break;} 
              } 
          } 
        } 
        cout<<ans<<endl; 
 
    } 
补充:软件开发 , C++ ,
CopyRight © 2022 站长资源库 编程知识问答 zzzyk.com All Rights Reserved
部分文章来自网络,